summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFolke H. Gleumes2022-08-10 20:05:04 +0200
committerFolke H. Gleumes2022-08-10 20:05:04 +0200
commita3ff43cf1187d1ab7a2afa686d3290ff8d22c3e4 (patch)
tree86c9983548860b7ab062ea3d0137b6226223e3f5
parent0629863ae3a7b13f81133ff478a526440c33b4fa (diff)
downloadaur-a3ff43cf1187d1ab7a2afa686d3290ff8d22c3e4.tar.gz
Add Makefile to ease publishing
-rw-r--r--Makefile16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..4004d385f6c9
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,16 @@
+release: clean build commit publish
+
+clean:
+ rm -rf kickoff* pkg src
+
+build:
+ makepkg
+ makepkg --printsrcinfo > .SRCINFO
+
+commit:
+ PKGVER=$$(grep -oP '(?<=pkgver\=)[\d\w\.]+' PKGBUILD)
+ git add PKGBUILD .SRCINFO
+ git commit -m "bump version: $(PKGVER)"
+
+publish:
+ git push