summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Teubner2017-07-22 13:48:32 +0100
committerCarlo Teubner2017-07-22 13:50:50 +0100
commit9d899414cc26dee9aee6425ba010f1c1f0b1cef8 (patch)
treecc357226276ea88f7be070a37c6bdf42b67954ca
downloadaur-9d899414cc26dee9aee6425ba010f1c1f0b1cef8.tar.gz
Initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD44
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1dbc3a4b58ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kickpass-git
+ pkgdesc = Stupid simple password safe
+ pkgver = v0.0.0.r220.gfafef62
+ pkgrel = 1
+ url = http://kickpass.pw/
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cmake
+ makedepends = check
+ depends = libsodium
+ depends = libbsd
+ depends = libevent
+ depends = libx11
+ provides = kickpass
+ conflicts = kickpass
+ source = git+https://github.com/kickpass/kickpass.git#branch=feature/libkickpass
+ sha256sums = SKIP
+
+pkgname = kickpass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3e035f4bc9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Carlo Teubner <carlo.teubner@gmail.com>
+
+# Please note that this package currently tracks branch 'feature/libkickpass'.
+# You may wish to change this to track a different branch (e.g., 'master' or
+# 'develop').
+
+pkgname=kickpass-git
+pkgver=v0.0.0.r220.gfafef62
+pkgrel=1
+pkgdesc="Stupid simple password safe"
+arch=('x86_64' 'i686')
+url="http://kickpass.pw/"
+license=('MIT')
+depends=('libsodium' 'libbsd' 'libevent' 'libx11')
+# makedepends=('cmake' 'python' 'python-pexpect' 'check' 'valgrind')
+# 'python', 'python-pexpect', 'valgrind' are only needed by the integration
+# tests, which we don't run (see below in 'check()' function).
+makedepends=('cmake' 'check')
+provides=('kickpass')
+conflicts=('kickpass')
+source=("git+https://github.com/kickpass/kickpass.git#branch=feature/libkickpass")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd kickpass
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd kickpass
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ cmake --build .
+}
+
+check() {
+ cd kickpass
+ # ctest # Running all tests takes a bit long. So run only unit tests:
+ ctest -R '^test-unit-.*'
+}
+
+package() {
+ cd kickpass
+ cmake --build . --target install -- DESTDIR="$pkgdir"
+}