summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-09 10:22:36 +0200
committerwillemw122015-06-09 10:22:36 +0200
commitec41cceaac7789ba04610b5358f3af29a7f72c37 (patch)
treeca147e794530eb61ed56a68abdeb85f0e668fc1d
downloadaur-ec41cceaac7789ba04610b5358f3af29a7f72c37.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--kiconedit.install12
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93b92a38d924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kiconedit
+ pkgdesc = KDE icon editor
+ pkgver = 4.4.0
+ pkgrel = 5
+ url = http://www.kde.org/applications/graphics/kiconedit
+ install = kiconedit.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = pkgconfig
+ makedepends = cmake
+ makedepends = automoc4
+ depends = kdebase-runtime
+ source = http://download.kde.org/stable/extragear/kiconedit-4.4.0.tar.bz2
+ md5sums = f2db6aff093cea2fcefceb3eb02a94c3
+
+pkgname = kiconedit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6c543c6caf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Sebastien Luttringer <seblu+arch@seblu.net>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+pkgname=kiconedit
+pkgver=4.4.0
+pkgrel=5
+pkgdesc="KDE icon editor"
+arch=('i686' 'x86_64')
+url="http://www.kde.org/applications/graphics/kiconedit"
+license=('GPL2')
+depends=('kdebase-runtime')
+makedepends=('pkgconfig' 'cmake' 'automoc4')
+install=$pkgname.install
+source=(http://download.kde.org/stable/extragear/$pkgname-$pkgver.tar.bz2)
+md5sums=('f2db6aff093cea2fcefceb3eb02a94c3')
+
+build() {
+ cd $pkgname-$pkgver
+
+ # Fix compilation handbook issue
+ sed -i '/add_subdirectory( hu_kiconedit\/kiconedit )/d' doc-translations/CMakeLists.txt
+
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/kiconedit.install b/kiconedit.install
new file mode 100644
index 000000000000..b0e216eba064
--- /dev/null
+++ b/kiconedit.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}