summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrhssk2021-12-20 10:37:39 +0200
committerrhssk2021-12-20 10:44:17 +0200
commit9fef8e4dde198a606aac5d8db634461d957b56af (patch)
treeb32c637697a6fafc13d9c8a5065f607950cc7680
parentb90e0fed9b8f5f8414164b42f90bf7f498557d90 (diff)
downloadaur-9fef8e4dde198a606aac5d8db634461d957b56af.tar.gz
Update upstream URLs, fix version format
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD24
2 files changed, 15 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d14aa27fdce..7cc00e37bd36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = kicost-git
pkgdesc = Build cost spreadsheet for a KiCad project
- pkgver = r915.72c887d
+ pkgver = 1.1.6.r1.227f246
pkgrel = 1
- url = https://xesscorp.github.io/KiCost
+ url = https://github.com/hildogjr/KiCost
arch = any
license = MIT
makedepends = git
@@ -19,8 +19,7 @@ pkgbase = kicost-git
depends = python-requests
provides = kicost
conflicts = kicost
- source = git+https://github.com/xesscorp/kicost.git
+ source = git+https://github.com/hildogjr/KiCost.git
sha256sums = SKIP
pkgname = kicost-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f31a49192c87..402904875066 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
-# Maintainer: rhssk <rssk@protonmail.com>
-pkgname='kicost-git'
-_gitname='kicost'
-pkgver=r915.72c887d
+# Maintainer: rhssk <rhssk@posteo.eu>
+pkgname=kicost-git
+_remotename=KiCost
+pkgver=1.1.6.r1.227f246
pkgrel=1
pkgdesc="Build cost spreadsheet for a KiCad project"
-url="https://xesscorp.github.io/KiCost"
+url="https://github.com/hildogjr/KiCost"
depends=(
'python'
'python-setuptools'
@@ -19,27 +19,27 @@ depends=(
'python-requests'
)
makedepends=('git')
-provides=("${_gitname}")
-conflicts=("${_gitname}")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
license=('MIT')
arch=('any')
-source=('git+https://github.com/xesscorp/kicost.git')
+source=('git+https://github.com/hildogjr/KiCost.git')
sha256sums=('SKIP')
pkgver() {
- cd "$_gitname"
+ cd "$_remotename"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
check() {
- cd "$_gitname"
+ cd "$_remotename"
python -m unittest tests.test_kicost
}
package() {
- cd "$_gitname"
+ cd "$_remotename"
python setup.py install --root="$pkgdir" --optimize=1
}