summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Daube2020-05-22 11:02:16 +0200
committerJulian Daube2020-05-22 11:02:16 +0200
commit41638015b3fc061d524e1df68380b20531334703 (patch)
tree728ce925d2577206a95a9f9acc517d8fa6345eeb
downloadaur-41638015b3fc061d524e1df68380b20531334703.tar.gz
initial version
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..644c8f4d03b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kikit-git
+ pkgdesc = KiKit is a Python library and CLI tool to automate several tasks in a standard KiCAD
+ pkgver = r65.c76c51e
+ pkgrel = 1
+ url = https://github.com/yaqwsx/KiKit.git
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-markdown2
+ depends = python-numpy
+ depends = python-shapely
+ depends = python-click
+ depends = python-pybars3
+ provides = kikit
+ source = kikit-git::git+https://github.com/yaqwsx/KiKit.git
+ md5sums = SKIP
+
+pkgname = kikit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8f3c9da3a77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Julian Daube <joposter at gmail dot com>
+# Contributor: Julian Daube <joposter at gmail dot com>
+pkgname=kikit-git
+pkgdesc="KiKit is a Python library and CLI tool to automate several tasks in a standard KiCAD"
+pkgver=r65.c76c51e
+pkgrel=1
+
+url="https://github.com/yaqwsx/KiKit.git"
+
+arch=("any")
+provides=("kikit")
+license=("MIT")
+
+source=("$pkgname::git+https://github.com/yaqwsx/KiKit.git")
+md5sums=("SKIP")
+makedepends=("python-setuptools")
+depends=("python-markdown2"
+ "python-numpy"
+ "python-shapely"
+ "python-click"
+ "python-pybars3"
+)
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ # install license
+ install -Dm 644 LICENCE "$pkgdir"/usr/share/licenses/kikit/LICENSE
+}