summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Schopf2020-12-29 09:52:27 +0100
committerDaniel Schopf2020-12-29 09:52:27 +0100
commit0b234a9cd0e5756bf9bf8d6560f15da6938c8999 (patch)
tree949e2a1db83fcd66dd24fc34fa926e2029f63d78
parentcbaff092cd4b8926df54bae66dbf57781b4e7f95 (diff)
downloadaur-0b234a9cd0e5756bf9bf8d6560f15da6938c8999.tar.gz
Update to v2.2.1 and clean up package
-rw-r--r--.SRCINFO10
-rw-r--r--Fix-Doxygen-command-error.patch12
-rw-r--r--PKGBUILD17
3 files changed, 12 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 95d543ce575a..114cd027532f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kim-api
pkgdesc = Online framework for reliable, reproducible and portable molecular simulations
- pkgver = 2.1.3
- pkgrel = 3
+ pkgver = 2.2.1
+ pkgrel = 1
url = https://openkim.org
install = kim-api.install
arch = i686
@@ -11,10 +11,8 @@ pkgbase = kim-api
makedepends = gcc-fortran
depends = xxd
optdepends = doxygen: build OpenKIM documentation
- source = https://s3.openkim.org/kim-api/kim-api-2.1.3.txz
- source = Fix-Doxygen-command-error.patch
- sha512sums = efbc0214234b43a65ed40d23d8faa5264ac1dbd056e9e340548ea7ee5dc530f9cfb2d85a1d9d47fba9dfc7aa660a8ec20374daf4aa8ee605e7c097ae2a12512d
- sha512sums = 0063cb18884a19d15261e910cc9877ff319f9c1b428023d736e34b5271f254a7eaca9b90033f80af560199e1fe363523da6afb4ee35a05af76b2760039a94cbd
+ source = https://s3.openkim.org/kim-api/kim-api-2.2.1.txz
+ sha512sums = b2625dc41474849f281f266a1fa8a2b1738d2433031d2181bde36ac5ec050fcdec3925cb588b287a46c80c01c730be04352ca88a9ba71fc3b37c2da1c84ae650
pkgname = kim-api
diff --git a/Fix-Doxygen-command-error.patch b/Fix-Doxygen-command-error.patch
deleted file mode 100644
index f5b99748d558..000000000000
--- a/Fix-Doxygen-command-error.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e328925d..5da8fcda 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -43,6 +43,7 @@ include(DefaultCompilerStandards)
-
- # Define options
- #
-+set(DOXYGEN_LATEX_MAKEINDEX_CMD makeindex)
- set(KIM_API_PROJECT_NAME "kim-api" CACHE STRING "KIM API project name string")
- mark_as_advanced(KIM_API_PROJECT_NAME)
- #
diff --git a/PKGBUILD b/PKGBUILD
index d031e5b32b04..e987884f8429 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Schopf <schopf.dan at gmail dot com>
pkgname=kim-api
-pkgver=2.1.3
-pkgrel=3
+pkgver=2.2.1
+pkgrel=1
pkgdesc="Online framework for reliable, reproducible and portable molecular simulations"
arch=("i686" "x86_64")
url="https://openkim.org"
@@ -10,15 +10,10 @@ depends=(xxd)
optdepends=('doxygen: build OpenKIM documentation')
makedepends=(cmake gcc-fortran)
install=$pkgname.install
-source=(https://s3.openkim.org/kim-api/kim-api-${pkgver}.txz
- Fix-Doxygen-command-error.patch)
-sha512sums=('efbc0214234b43a65ed40d23d8faa5264ac1dbd056e9e340548ea7ee5dc530f9cfb2d85a1d9d47fba9dfc7aa660a8ec20374daf4aa8ee605e7c097ae2a12512d'
- '0063cb18884a19d15261e910cc9877ff319f9c1b428023d736e34b5271f254a7eaca9b90033f80af560199e1fe363523da6afb4ee35a05af76b2760039a94cbd')
+source=(https://s3.openkim.org/kim-api/kim-api-${pkgver}.txz)
+sha512sums=('b2625dc41474849f281f266a1fa8a2b1738d2433031d2181bde36ac5ec050fcdec3925cb588b287a46c80c01c730be04352ca88a9ba71fc3b37c2da1c84ae650')
prepare() {
- cd "$pkgname-$pkgver"
- patch -p1 -i ../Fix-Doxygen-command-error.patch
- cd ..
mkdir -p build
}
@@ -38,4 +33,8 @@ build() {
package() {
cd build
make DESTDIR="$pkgdir" install
+ cd "$pkgdir"/usr/share/emacs/site-lisp
+ mv kim-api/*.el .
+ rmdir kim-api
+ cd ../../..
}