summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Schopf2020-02-16 10:03:03 +0100
committerDaniel Schopf2020-02-16 10:03:03 +0100
commit46056c16decc877d9683ac9e844c9a00540f59b7 (patch)
treec54947784d875bb3d58c8f8b8abfb30facfc8b2d
parentd88bc4adb03b30e8b9196512038232adefbbac72 (diff)
downloadaur-46056c16decc877d9683ac9e844c9a00540f59b7.tar.gz
Don't remove cmake files and store completions in correct folders
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 4 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df2c691c0bb7..b9d6139093d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kim-api
pkgdesc = Online framework for reliable, reproducible and portable molecular simulations
pkgver = 2.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://openkim.org
install = kim-api.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 3c5fd2f29af7..2965bb5db1ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Schopf <schopf.dan at gmail dot com>
pkgname=kim-api
pkgver=2.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Online framework for reliable, reproducible and portable molecular simulations"
arch=("i686" "x86_64")
url="https://openkim.org"
@@ -29,6 +29,8 @@ build() {
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-DCMAKE_INSTALL_LIBEXECDIR="/usr/lib" \
+ -DBASH_COMPLETION_COMPLETIONSDIR="/usr/share/bash-completion/completions" \
+ -DZSH_COMPLETION_COMPLETIONSDIR="/usr/share/zsh/functions/Completion/Unix" \
-DKIM_API_BUILD_EXAMPLES=ON
make
}
@@ -36,8 +38,4 @@ build() {
package() {
cd build
make DESTDIR="$pkgdir" install
-
- # remove empty directories
- cd "$pkgdir"
- rm -rf usr/share
}