summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Lisin2022-11-22 12:49:15 +0100
committerMatthias Lisin2022-11-22 12:49:15 +0100
commit55eec01b1d56aed85e8b98e8b58ae330775c7908 (patch)
tree4ec491248e6f0dc0fb4a801e5fc2d4e7cee9c3db
parent0eb012633c9a9a8c47d5540a38f34179907bc0a3 (diff)
downloadaur-55eec01b1d56aed85e8b98e8b58ae330775c7908.tar.gz
upgpkg: kind 0.17.0-2
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--kind.install9
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5aade0a3f327..f6a537f80aff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kind
pkgdesc = Kubernetes IN Docker - local clusters for testing Kubernetes
pkgver = 0.17.0
- pkgrel = 1
+ pkgrel = 2
url = https://kind.sigs.k8s.io/
install = kind.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4476d032dc55..ca2ffaf013b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: ml <>
pkgname=kind
pkgver=0.17.0
-pkgrel=1
+pkgrel=2
pkgdesc='Kubernetes IN Docker - local clusters for testing Kubernetes'
arch=('x86_64' 'aarch64')
url='https://kind.sigs.k8s.io/'
diff --git a/kind.install b/kind.install
index d9e3f54847ff..1a970b73d149 100644
--- a/kind.install
+++ b/kind.install
@@ -1,11 +1,12 @@
# vim: ft=bash
post_install() {
echo "\
- Rootless docker/podman (with cgroups v2) is supported starting >=0.11.0
- Checkout the guide: https://kind.sigs.k8s.io/docs/user/rootless/
+ To use podman instead of docker:
+ systemd-run --setenv=KIND_EXPERIMENTAL_PROVIDER=podman --scope --user kind create cluster
- To use podman instead of docker, run
- KIND_EXPERIMENTAL_PROVIDER=podman kind create cluster"
+ For explanation see:
+ https://github.com/kubernetes-sigs/kind/pull/2981
+ https://github.com/kubernetes-sigs/kind/issues/2872"
}
post_upgrade() { post_install; }