summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Weald2019-06-11 19:32:18 +0100
committerSimon Weald2019-06-11 19:32:18 +0100
commit1186c5634f5e92a9df776b81dbf3c9b7d52033a4 (patch)
tree2280024931e885556c5867c2ca44ecc05424b6c1
parent3d30b86b22e9b29162fcdc43b3c50c0d5085b091 (diff)
downloadaur-1186c5634f5e92a9df776b81dbf3c9b7d52033a4.tar.gz
add bash completion and add tongpu as a co-maintainer
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9064a1b90767..7ca856d3228a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kind-bin
pkgdesc = Kubernetes IN Docker - local clusters for testing Kubernetes
pkgver = 0.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/kubernetes-sigs/kind
arch = x86_64
license = apache
diff --git a/PKGBUILD b/PKGBUILD
index 06933b84a980..39bda6490592 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Simon Weald <simon[at]simonweald[dot]com>
+# Maintainer: Lukas Grossar <lukas[dot]grossar[at]gmail[dot]com>
pkgname=kind-bin
pkgdesc="Kubernetes IN Docker - local clusters for testing Kubernetes"
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url="https://github.com/kubernetes-sigs/kind"
license=('apache')
@@ -13,4 +14,8 @@ sha256sums=('4d133e28c639595eaafce281cc2508a1bf9aa901259b23e749a97a3e712b6f36')
package() {
install -Dm 755 "$srcdir/$_binary-$pkgver" "$pkgdir/usr/bin/kind"
+
+ "$pkgdir/usr/bin/kind" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/kind"
+ "$pkgdir/usr/bin/kind" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_kind"
}
+