summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2022-05-20 12:46:57 +0200
committerLukas Grossar2022-05-20 12:46:57 +0200
commit77470b25ea23cbe57cff1d36b4ba3202187ce813 (patch)
tree7d53d0a322f00cc42269919234223e603c47f0e6
parentf963fd0b06cb430abd96a3f5aa13b329fd937ac3 (diff)
downloadaur-77470b25ea23cbe57cff1d36b4ba3202187ce813.tar.gz
update to v0.14.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15810cadf5d3..48ef48c2bed8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = kind-bin
pkgdesc = Kubernetes IN Docker - local clusters for testing Kubernetes
- pkgver = 0.13.0
+ pkgver = 0.14.0
pkgrel = 1
url = https://github.com/kubernetes-sigs/kind
arch = x86_64
license = Apache
provides = kind
conflicts = kind
- source = kind-linux-amd64-0.13.0::https://github.com/kubernetes-sigs/kind/releases/download/v0.13.0/kind-linux-amd64
- sha256sums = c80c6d1013337cbbe226c2eda0a3dc2d75af16e5fa8af4ce3fc9fedcf1f9d2dc
+ source = kind-linux-amd64-0.14.0::https://github.com/kubernetes-sigs/kind/releases/download/v0.14.0/kind-linux-amd64
+ sha256sums = af5e8331f2165feab52ec2ae07c427c7b66f4ad044d09f253004a20252524c8b
pkgname = kind-bin
diff --git a/PKGBUILD b/PKGBUILD
index 434ea3934298..6df7a3be0e03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=kind-bin
pkgdesc="Kubernetes IN Docker - local clusters for testing Kubernetes"
-pkgver=0.13.0
+pkgver=0.14.0
pkgrel=1
arch=('x86_64')
url="https://github.com/kubernetes-sigs/kind"
@@ -12,11 +12,12 @@ provides=('kind')
conflicts=('kind')
_binary=kind-linux-amd64
source=("$_binary-$pkgver::https://github.com/kubernetes-sigs/kind/releases/download/v$pkgver/$_binary")
-sha256sums=('c80c6d1013337cbbe226c2eda0a3dc2d75af16e5fa8af4ce3fc9fedcf1f9d2dc')
+sha256sums=('af5e8331f2165feab52ec2ae07c427c7b66f4ad044d09f253004a20252524c8b')
package() {
install -Dm 755 "$srcdir/$_binary-$pkgver" "$pkgdir/usr/bin/kind"
"$pkgdir/usr/bin/kind" completion bash | install -Dm644 /dev/stdin "$pkgdir/usr/share/bash-completion/completions/kind"
"$pkgdir/usr/bin/kind" completion zsh | install -Dm644 /dev/stdin "$pkgdir/usr/share/zsh/site-functions/_kind"
+ "$pkgdir/usr/bin/kind" completion fish | install -Dm644 /dev/stdin "$pkgdir/usr/share/fish/vendor_completions.d/kind.fish"
}