summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorValentin Hăloiu2015-06-10 02:19:57 +0300
committerValentin Hăloiu2015-06-10 02:19:57 +0300
commitf21a6fa6f144ea29552f7a90401fabd7fbd17a56 (patch)
tree32e210bfdf8f218ad834525a813ffd84dc55ee3a
downloadaur-f21a6fa6f144ea29552f7a90401fabd7fbd17a56.tar.gz
Add initial files
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a501e748529d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kindlegen
+ pkgdesc = A command line tool used to build eBooks that can be sold through Amazon's Kindle platform.
+ pkgver = 2.9
+ pkgrel = 4
+ url = https://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000765211
+ arch = i686
+ arch = x86_64
+ license = custom
+ source = https://s3.amazonaws.com/kindlegen/kindlegen_linux_2.6_i386_v2_9.tar.gz
+ md5sums = 21aef3c8846946203e178c83a37beba1
+
+pkgname = kindlegen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9835f27cabf9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Valentin-Costel Haloiu <vially.ichb@gmail.com>
+# Contributor: Eugene Yunak <e.yunak@gmail.com>
+
+pkgname=kindlegen
+pkgver=2.9
+pkgrel=4
+pkgdesc="A command line tool used to build eBooks that can be sold through Amazon's Kindle platform."
+arch=('i686' 'x86_64')
+url="https://www.amazon.com/gp/feature.html?ie=UTF8&docId=1000765211"
+license=(custom)
+source=("https://s3.amazonaws.com/${pkgname}/${pkgname}_linux_2.6_i386_v${pkgver/\./_}.tar.gz")
+md5sums=('21aef3c8846946203e178c83a37beba1')
+
+package() {
+ install -D -m755 $srcdir/kindlegen $pkgdir/usr/bin/kindlegen
+
+ # install license files
+ mkdir -p $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 "$srcdir/KindleGen Legal Notices 2013-02-19 Linux.txt" $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 $srcdir/EULA.txt $pkgdir/usr/share/licenses/$pkgname/
+}