summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikołaj "D1SoveR" Banasik2021-06-12 12:09:25 +0100
committerMikołaj "D1SoveR" Banasik2021-06-12 12:09:25 +0100
commitcd5f7800244896522ef3c600e618799f2781aef3 (patch)
treed2d97e01f2ae8a0de8e2e470a312764c2c8cc6fb
parent6d5861188d96a5ebed74f0ab919704664cc47d11 (diff)
downloadaur-cd5f7800244896522ef3c600e618799f2781aef3.tar.gz
Updated the hash for MSI file contained the firmware.
It appears Microsoft updated the MSI file at some point recently; firmware file is the exact same though.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--updated-hash.patch17
3 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2adf9bd7369e..a790c31d72ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kinect-audio-setup
pkgdesc = Tools to download and apply USB Audio Class firmware for Kinect and use it as microphone
pkgver = 0.5
- pkgrel = 1
+ pkgrel = 2
url = https://git.ao2.it/kinect-audio-setup.git
install = kinect-audio-setup.install
arch = x86_64
@@ -14,10 +14,12 @@ pkgbase = kinect-audio-setup
depends = p7zip>=9.20
source = git+https://git.ao2.it/kinect-audio-setup.git#tag=v0.5
source = improved-fetch.patch
+ source = updated-hash.patch
source = 55-kinect-audio.rules
source = LICENSE
sha256sums = SKIP
sha256sums = a27b9e1cffd9c5f062fd15c494e12fdf8bc73e5ae590329bf40eabe16f731c79
+ sha256sums = b94f922466b5796e09bc22457654b53fffa138c21c5f6045a13b67824a94e4c9
sha256sums = 8f9f343eeed07c59c65940f4a03814da5e2018cdbc331664bfacc2c98cd7d549
sha256sums = d23efd383bc03aa8cdeac33be24a9c915f05ad92d20f4070e7160bdcff7f4a8c
diff --git a/PKGBUILD b/PKGBUILD
index fdd985e8699e..103f8a5144b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mikołaj "D1SoveR" Banasik <d1sover@gmail.com>
pkgname='kinect-audio-setup'
pkgver=0.5
-pkgrel=1
+pkgrel=2
pkgdesc='Tools to download and apply USB Audio Class firmware for Kinect and use it as microphone'
arch=('x86_64' 'i686')
url='https://git.ao2.it/kinect-audio-setup.git'
@@ -12,16 +12,19 @@ install="${pkgname}.install"
source=("git+${url}#tag=v${pkgver}"
'improved-fetch.patch'
+ 'updated-hash.patch'
'55-kinect-audio.rules'
'LICENSE')
sha256sums=('SKIP'
'a27b9e1cffd9c5f062fd15c494e12fdf8bc73e5ae590329bf40eabe16f731c79'
+ 'b94f922466b5796e09bc22457654b53fffa138c21c5f6045a13b67824a94e4c9'
'8f9f343eeed07c59c65940f4a03814da5e2018cdbc331664bfacc2c98cd7d549'
'd23efd383bc03aa8cdeac33be24a9c915f05ad92d20f4070e7160bdcff7f4a8c')
prepare() {
cd "$pkgname"
patch -Np1 -i "${srcdir}/improved-fetch.patch"
+ patch -Np1 -i "${srcdir}/updated-hash.patch"
}
build() {
diff --git a/updated-hash.patch b/updated-hash.patch
new file mode 100644
index 000000000000..da813386afbc
--- /dev/null
+++ b/updated-hash.patch
@@ -0,0 +1,17 @@
+It appears that Microsoft has modified the MSI file some time before 11th of June 2021, and it now has a different hash.
+I've compared the files from old and new version of the MSI file and none of its contents are different (most importantly,
+the firmware we utilise is the exact same), so the simplest fix is just to update the hash.
+
+diff --git a/kinect_fetch_fw b/kinect_fetch_fw
+index 91b1289..d058b70 100755
+--- a/kinect_fetch_fw
++++ b/kinect_fetch_fw
+@@ -13,7 +13,7 @@
+ set -e
+
+ SDK_URL=${SDK_URL:-"http://download.microsoft.com/download/F/9/9/F99791F2-D5BE-478A-B77A-830AD14950C3/KinectSDK-v1.0-beta2-x86.msi"}
+-SDK_MD5="40764fe9e00911bda5095e5be777e311"
++SDK_MD5="945806927702b2c47c32125ab9a80344"
+
+ [ $# -lt 1 ] && { echo "usage: $(basename "$0") <firmware destdir>" 1>&2; exit 1; }
+ FW_DESTDIR=$(readlink -m $1)