summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Orefice2015-09-30 13:31:49 +0200
committerAntonio Orefice2015-09-30 13:31:49 +0200
commita8e17eda9612a102a8ff493aa219536440384dee (patch)
tree0d3ab6aa92e6196b795701f6b60173796b0ef0bc
downloadaur-a8e17eda9612a102a8ff493aa219536440384dee.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--kingbash-gb.install44
3 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17f7e1f09d3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kingbash-gb-git
+ pkgdesc = Menu driven auto-completion for bash terminals under X
+ pkgver = 20150930
+ pkgrel = 1
+ url = https://github.com/kokoko3k/kingbash-gb
+ install = kingbash-gb.install
+ arch = any
+ license = gpl
+ makedepends = gambas3-devel
+ makedepends = git
+ depends = bash
+ depends = gambas3-gb-desktop>=3.6.2
+ depends = gambas3-gb-desktop-x11
+ depends = gambas3-gb-form>=3.6.2
+ depends = gambas3-gb-image>=3.6.2
+ depends = gambas3-gb-qt4>=3.6.2
+
+pkgname = kingbash-gb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c864823dfa45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer : Antonio Orefice <xt7player@gmail.com>
+
+pkgname=kingbash-gb-git
+pkgver=20150930
+pkgrel=1
+pkgdesc="Menu driven auto-completion for bash terminals under X"
+arch=('any')
+url="https://github.com/kokoko3k/kingbash-gb"
+license=('gpl')
+
+depends=(
+ 'bash'
+ 'gambas3-gb-desktop>=3.6.2'
+ 'gambas3-gb-desktop-x11'
+ 'gambas3-gb-form>=3.6.2'
+ 'gambas3-gb-image>=3.6.2'
+ 'gambas3-gb-qt4>=3.6.2'
+ )
+
+makedepends=('gambas3-devel' 'git')
+
+_gitroot="https://github.com/kokoko3k/kingbash-gb"
+
+build() {
+ cd $srcdir
+ rm -Rf $srcdir/kingbash-gb &>/dev/null || echo "No old repository found, proceding to git clone..."
+ git clone --depth 1 $_gitroot || return 1
+
+ cd $srcdir/kingbash-gb
+
+ gbc3 -e -a -g -t -p -m
+ gba3
+}
+
+package() {
+ cd kingbash-gb
+ install -d ${pkgdir}/usr/bin
+ install -m755 kingbash-gb.gambas ${pkgdir}/usr/bin/kingbash-gb.gambas
+}
+
+install=kingbash-gb.install
diff --git a/kingbash-gb.install b/kingbash-gb.install
new file mode 100644
index 000000000000..71d9a2401cfc
--- /dev/null
+++ b/kingbash-gb.install
@@ -0,0 +1,44 @@
+post_install() {
+ echo ''
+ echo 'To use kingbash-gb, append the following to your ~/.bashrc :'
+ echo ''
+ echo ''
+ echo ' kingbash.gb() {'
+ echo ' OUTPUT=$(/usr/local/bin/kingbash-gb.gambas "$READLINE_LINE" "$READLINE_POINT")'
+ echo ' READLINE_POINT=$(echo "$OUTPUT"|tail -n1)'
+ echo ' READLINE_LINE=$(echo "$OUTPUT"|head -n1)'
+ echo ' }'
+ echo ''
+ echo ' if [ "$DISPLAY" != "" ]; then'
+ echo ' #bind -x '"\C-e": kingbash.gb' #for Use with Ctrl-e'
+ echo ' bind -x '"\t": kingbash.gb' #for Use with Tab'
+ echo ' fi'
+ echo ''
+ echo ''
+ echo 'Next, and open a new bash terminal and try autocompletion with <TAB> key'
+ echo ''
+
+}
+
+post_upgrade() {
+ echo ''
+ echo 'To use kingbash-gb, append the following to your ~/.bashrc :'
+ echo ''
+ echo ''
+ echo ' kingbash.gb() {'
+ echo ' OUTPUT=$(/usr/local/bin/kingbash-gb.gambas "$READLINE_LINE" "$READLINE_POINT")'
+ echo ' READLINE_POINT=$(echo "$OUTPUT"|tail -n1)'
+ echo ' READLINE_LINE=$(echo "$OUTPUT"|head -n1)'
+ echo ' }'
+ echo ''
+ echo ' if [ "$DISPLAY" != "" ]; then'
+ echo ' #bind -x '"\C-e": kingbash.gb' #for Use with Ctrl-e'
+ echo ' bind -x '"\t": kingbash.gb' #for Use with Tab'
+ echo ' fi'
+ echo ''
+ echo ''
+ echo 'Next, and open a new bash terminal and try autocompletion with <TAB> key'
+ echo ''
+
+}
+