summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 13:58:07 -0600
committerJohn D Jones III2015-06-16 13:58:07 -0600
commitccf008985fffdb2156104070c19c1991ab6599f0 (patch)
treeb944516db786928b18589ce8dbe926e5651e9675
downloadaur-ccf008985fffdb2156104070c19c1991ab6599f0.tar.gz
Initial import
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD28
-rw-r--r--kingfisher.install34
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c1e94cf5fb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = kingfisherqm
+ pkgdesc = Backend for Cups - count correct pages and administration
+ pkgver = 0.0.3
+ pkgrel = 5
+ url = http://sourceforge.net/projects/kingfisherqm/
+ install = kingfisher.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = postgresql
+ depends = postgresql-libs
+ depends = cups
+ depends = php
+ depends = php-apache
+ depends = apache
+ depends = perl
+ depends = perl-proc-daemon
+ depends = perl-proc-pid-file
+ depends = perl-dbd-pg
+ depends = perl-ipc-shareable
+ depends = perl-gdgraph
+ depends = perl-gdgraph-3d
+ depends = python
+ depends = pkpgcounter
+ options = !makeflags
+ backup = etc/kingfisher/kingfisher.conf
+ source = http://sourceforge.net/projects/kingfisherqm/files/kingfisherqm/0.0.3/kingfisherqm-0.0.3.tar.gz/download
+ source = kingfisher.install
+ md5sums = 9849252841240d87e89196060b9054e2
+ md5sums = ab1c8d8acf5cc8094b49def4953fac6d
+
+pkgname = kingfisherqm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1483c0cd33f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+pkgname=kingfisherqm
+pkgver=0.0.3
+pkgrel=5
+pkgdesc="Backend for Cups - count correct pages and administration"
+arch=(i686 x86_64)
+license=('GPL')
+backup=('etc/kingfisher/kingfisher.conf')
+url="http://sourceforge.net/projects/kingfisherqm/"
+depends=("postgresql" "postgresql-libs" "cups" "php" "php-apache" "apache" "perl" "perl-proc-daemon" "perl-proc-pid-file" "perl-dbd-pg" "perl-ipc-shareable" "perl-gdgraph" "perl-gdgraph-3d" "python" "pkpgcounter")
+options=('!makeflags')
+install=('kingfisher.install')
+source=("http://sourceforge.net/projects/${pkgname}/files/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz/download" kingfisher.install)
+md5sums=('9849252841240d87e89196060b9054e2'
+ 'ab1c8d8acf5cc8094b49def4953fac6d')
+
+package() {
+ cd $srcdir
+ bsdtar xf "$SRCDEST/download"
+
+ # Copy others files
+ mv $startdir/src/${pkgname}/etc/init.d $startdir/src/${pkgname}/etc/rc.d
+ cp -R $startdir/src/${pkgname}/etc $startdir/src/${pkgname}/usr $startdir/pkg
+
+ # Creating directory /var/spool/kingfisher
+ mkdir -p $startdir/pkg/var/spool/kingfisher
+ chmod -R 0777 $startdir/pkg/var/spool/kingfisher
+}
diff --git a/kingfisher.install b/kingfisher.install
new file mode 100644
index 000000000000..34af547ab34e
--- /dev/null
+++ b/kingfisher.install
@@ -0,0 +1,34 @@
+_install_notes() {
+ echo
+ echo '---------------------------------------------------------------------------'
+ echo ' IMPORTANT NOTES:'
+ echo
+ echo "IMPORTANT: Now, create tables in database with /usr/share/doc/kingfisher/kingfisher.pg.sql"
+ echo "And edit /etc/kingfisher/kingfisher.conf and /srv/http/kingfisher/inc/config.inc.php"
+ echo "Init Kingfisher Daemon with: /etc/rc.d/kingfisherd start"
+ echo "Configure httpd.conf and php.ini with pdo"
+ echo ""
+ echo "Ex. Create Database"
+ echo "$su postgres"
+ echo "$psql"
+ echo "postgres=# CREATE DATABASE kingfisher;"
+ echo "postgres=# CREATE USER kingfisher;"
+ echo "postgres=# \password kingfisher;"
+ echo "postgres=# \i /usr/share/doc/kingfisher/kingfisher.pg.sql;"
+ echo "\q"
+ echo "---------------------------------------------------------------------------"
+}
+
+# $1: The new package version
+post_install() {
+ _install_notes
+}
+
+post_upgrade() {
+ _install_notes
+}
+
+pre_remove() {
+ killall kingfisherd
+}
+