summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConnor Behan2015-06-08 21:24:05 -0400
committerConnor Behan2015-06-08 21:24:05 -0400
commitdf6dcf237103a72fdca45ebbed1b2a3bbbba5e03 (patch)
tree868de9b0c5713272649110c1669bff72d439fc78
downloadaur-df6dcf237103a72fdca45ebbed1b2a3bbbba5e03.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD35
-rw-r--r--kino.install13
-rw-r--r--videodev-header.patch26
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a790482d0f51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = kino
+ pkgdesc = A non-linear DV editor
+ pkgver = 1.3.4
+ pkgrel = 5
+ url = http://www.kinodv.org/
+ install = kino.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = intltool
+ makedepends = v4l-utils
+ depends = libavc1394
+ depends = libiec61883
+ depends = libdv
+ depends = libglade
+ depends = libxv
+ depends = libsamplerate
+ depends = libsm
+ depends = desktop-file-utils
+ source = http://downloads.sourceforge.net/kino/kino-1.3.4.tar.gz
+ source = videodev-header.patch
+ md5sums = 52f8ce690e45a089e3edc6c7af61a05c
+ md5sums = 940404c0eec3c9d954c289ceb52d15a6
+
+pkgname = kino
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae30de856f5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer:
+# Contributor: Robert Emil Berge <robert@rebi.no>
+
+pkgname=kino
+pkgver=1.3.4
+pkgrel=5
+pkgdesc="A non-linear DV editor"
+arch=('i686' 'x86_64')
+url="http://www.kinodv.org/"
+license=('GPL')
+depends=('libavc1394' 'libiec61883' 'libdv' 'libglade' 'libxv' 'libsamplerate' 'libsm' 'desktop-file-utils')
+makedepends=('intltool' 'v4l-utils')
+install=kino.install
+source=("http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'videodev-header.patch')
+md5sums=('52f8ce690e45a089e3edc6c7af61a05c'
+ '940404c0eec3c9d954c289ceb52d15a6')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ patch -p1 -i "${srcdir}"/videodev-header.patch
+
+ ./configure --prefix=/usr \
+ --with-udev-rules-dir=/usr/lib/udev/rules.d
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+
+ # Fix permissions
+ chown -R root:root "${pkgdir}/usr/share/kino/help"
+}
diff --git a/kino.install b/kino.install
new file mode 100644
index 000000000000..83b78df923e7
--- /dev/null
+++ b/kino.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-mime-database usr/share/mime 1> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ update-mime-database usr/share/mime 1> /dev/null
+ update-desktop-database -q
+}
diff --git a/videodev-header.patch b/videodev-header.patch
new file mode 100644
index 000000000000..01394fc4710f
--- /dev/null
+++ b/videodev-header.patch
@@ -0,0 +1,26 @@
+Index: kino-1.3.4/ffmpeg/libavdevice/v4l.c
+===================================================================
+--- kino-1.3.4.orig/ffmpeg/libavdevice/v4l.c 2011-04-11 15:12:41.915593967 +0200
++++ kino-1.3.4/ffmpeg/libavdevice/v4l.c 2011-04-11 15:13:05.825593979 +0200
+@@ -26,7 +26,7 @@
+ #include <sys/mman.h>
+ #include <sys/time.h>
+ #define _LINUX_TIME_H 1
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+ #include <time.h>
+
+ typedef struct {
+Index: kino-1.3.4/src/v4l.h
+===================================================================
+--- kino-1.3.4.orig/src/v4l.h 2011-04-11 15:12:41.895593967 +0200
++++ kino-1.3.4/src/v4l.h 2011-04-11 15:12:57.555593975 +0200
+@@ -40,7 +40,7 @@
+
+ #define _DEVICE_H_
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+
+ #include "displayer.h"
+