summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 22:45:23 +0200
committerAntonio Rojas2015-06-08 22:45:23 +0200
commitefaacf141429fe8b6588b444feba4ef67351b766 (patch)
tree3a74e2557edd498e822f8f8127467c8bd6df6060
downloadaur-efaacf141429fe8b6588b444feba4ef67351b766.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD44
-rw-r--r--kio-git.install11
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4ae5aa8eea36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = kio-git
+ pkgdesc = Resource and network access abstraction
+ pkgver = r1598.8b43a9e
+ pkgrel = 1
+ url = https://projects.kde.org/projects/frameworks/kio
+ install = kio-git.install
+ arch = i686
+ arch = x86_64
+ groups = kf5
+ license = LGPL
+ makedepends = extra-cmake-modules-git
+ makedepends = git
+ makedepends = kdoctools
+ depends = karchive-git
+ depends = kbookmarks-git
+ depends = kjobwidgets-git
+ depends = kwallet-git
+ depends = solid-git
+ depends = libxslt
+ depends = desktop-file-utils
+ provides = kio
+ conflicts = kio
+ source = git://anongit.kde.org/kio.git
+ md5sums = SKIP
+
+pkgname = kio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35471c05ccc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=kio-git
+pkgver=r1598.8b43a9e
+pkgrel=1
+pkgdesc='Resource and network access abstraction'
+arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/frameworks/kio'
+license=('LGPL')
+depends=('karchive-git' 'kbookmarks-git' 'kjobwidgets-git' 'kwallet-git' 'solid-git' 'libxslt' 'desktop-file-utils')
+makedepends=('extra-cmake-modules-git' 'git' 'kdoctools')
+groups=('kf5')
+conflicts=(kio)
+provides=(kio)
+install=$pkgname.install
+source=('git://anongit.kde.org/kio.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd kio
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kio \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DLIBEXEC_INSTALL_DIR=lib \
+ -DBUILD_TESTING=OFF \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/kio-git.install b/kio-git.install
new file mode 100644
index 000000000000..e111ef946053
--- /dev/null
+++ b/kio-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}