summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen Booth2015-06-23 09:43:25 -0700
committerBen Booth2015-06-23 09:43:25 -0700
commit32bae510888275235a8e874ba5e81e32d342546f (patch)
tree076c1e649d35806566d45558314dce848e53bb9a
downloadaur-kiofuse-svn.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
-rw-r--r--add-missing-includes.patch28
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12ca97669336
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kiofuse-svn
+ pkgdesc = KioFuse allows you to mount remote directories into the root hierarchy of your local file system, thereby exposing KDE's advanced access capabilities (SSH, SAMBA/Windows, FTP, TAR/GZip/BZip2, WebDav, etc) to POSIX-compliant applications.
+ pkgver = 1360808
+ pkgrel = 2
+ url = http://techbase.kde.org/Projects/KioFuse
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = subversion
+ makedepends = cmake
+ depends = kdelibs>=4
+ source = add-missing-includes.patch
+ md5sums = fb3e710a62f34f79fa1166d3e25a5eef
+
+pkgname = kiofuse-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d18c513c394
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer:Ben Booth <benwbooth@gmail.com>
+pkgname=kiofuse-svn
+pkgver=1360808
+pkgrel=2
+pkgdesc="KioFuse allows you to mount remote directories into the root hierarchy of your local file system, thereby exposing KDE's advanced access capabilities (SSH, SAMBA/Windows, FTP, TAR/GZip/BZip2, WebDav, etc) to POSIX-compliant applications."
+arch=('i686' 'x86_64')
+url="http://techbase.kde.org/Projects/KioFuse"
+license=('LGPL')
+groups=()
+depends=('kdelibs>=4')
+makedepends=('subversion' 'cmake')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=('add-missing-includes.patch')
+noextract=()
+md5sums=('fb3e710a62f34f79fa1166d3e25a5eef')
+
+_svntrunk=svn://anonsvn.kde.org/home/kde/trunk/playground/libs/kiofuse
+_svnmod=kiofuse
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to SVN server...."
+
+ if [[ -d "$_svnmod/.svn" ]]; then
+ (cd "$_svnmod" && svn up -r "$pkgver")
+ else
+ svn co "$_svntrunk" --config-dir ./ -r "$pkgver" "$_svnmod"
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_svnmod-build"
+ svn export "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build"
+
+ patch -p0 -i ../add-missing-includes.patch
+
+ cmake .
+ make
+}
+
+package() {
+ cd "$srcdir/$_svnmod-build"
+ install -Dm755 kiofuse "$pkgdir/usr/bin/kiofuse"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/add-missing-includes.patch b/add-missing-includes.patch
new file mode 100644
index 000000000000..e94638d0e6f9
--- /dev/null
+++ b/add-missing-includes.patch
@@ -0,0 +1,28 @@
+Index: kiofuseapp.h
+===================================================================
+--- kiofuseapp.h (revision 1360808)
++++ kiofuseapp.h (working copy)
+@@ -22,6 +22,9 @@
+ #define KIO_FUSE_APP_H
+
+ #include <errno.h>
++extern "C" {
++#include <stdint.h>
++}
+
+ #include "cache.h"
+ #include "jobhelpers.h"
+Index: kiofuseops.cpp
+===================================================================
+--- kiofuseops.cpp (revision 1360808)
++++ kiofuseops.cpp (working copy)
+@@ -24,6 +24,9 @@
+ #include <QThread>
+
+ #include <kdebug.h>
++extern "C" {
++#include <unistd.h>
++}
+
+ int kioFuseGetAttr(const char *relPath, struct stat *stbuf)
+ {