summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Manna2015-12-05 00:26:09 -0800
committerKyle Manna2015-12-05 00:26:38 -0800
commit55acc43f5560012674076511ebeb858b0c292973 (patch)
tree2429b302b6bbb21539f2d8ba5428a370aed431be
downloadaur-55acc43f5560012674076511ebeb858b0c292973.tar.gz
release: v0.1.13
* Initial release.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD27
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..360c9e6e0771
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Dec 5 08:26:30 UTC 2015
+pkgbase = kipart
+ pkgdesc = Python package for generating multi-unit schematic symbols for KiCad from a CSV file
+ pkgver = 0.1.13
+ pkgrel = 1
+ url = https://github.com/xesscorp/KiPart
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-pip
+ depends = python-affine
+ depends = python-future
+ source = https://pypi.python.org/packages/source/k/kipart/kipart-0.1.13.zip
+ sha512sums = a06ef6ab001c3125492dbb934428b94dc8b965458866783a970fa6a68a89cf9b8663dcf7c5c80b6e07c76b4ba257f6412e00d56714f09489362e05280d3fc4ac
+
+pkgname = kipart
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..27a2b46868cd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.xz
+*.tar.gz
+*.zip
+*.csv
+/src
+/pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..052781ac245c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kyle Manna <kyle[at]kylemanna[d0t]com>
+pkgname=kipart
+pkgver=0.1.13
+pkgrel=1
+pkgdesc="Python package for generating multi-unit schematic symbols for KiCad from a CSV file"
+url="https://github.com/xesscorp/KiPart"
+depends=('python'
+ 'python-pip'
+ 'python-affine'
+ 'python-future'
+)
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/k/${pkgname}/${pkgname}-${pkgver}.zip")
+sha512sums=('a06ef6ab001c3125492dbb934428b94dc8b965458866783a970fa6a68a89cf9b8663dcf7c5c80b6e07c76b4ba257f6412e00d56714f09489362e05280d3fc4ac')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+