summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-01-07 19:43:37 +1300
committerGeorge Rawlinson2023-01-07 19:43:37 +1300
commitfb8ebbd7a4a04a9759d641c1560cccd2c459172f (patch)
tree931017f2bd82cf63024c8fe34f7016d45ebe27e7
parentedef01c2cf1fedae31ff46aefe6be7fcad61b61e (diff)
downloadaur-fb8ebbd7a4a04a9759d641c1560cccd2c459172f.tar.gz
upgpkg: kirc 0.3.2-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
-rw-r--r--skip-clean.patch11
3 files changed, 33 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e55fb765b10..adb29d2f732e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = kirc
pkgdesc = A tiny IRC client written in POSIX C99
- pkgver = 0.3.1
+ pkgver = 0.3.2
pkgrel = 1
url = https://github.com/mcpcpc/kirc
arch = x86_64
license = MIT
makedepends = git
depends = glibc
- source = kirc::git+https://github.com/mcpcpc/kirc.git#commit=851eed53dd3f251c6d85bd43325ccbe658f39a4d
+ source = kirc::git+https://github.com/mcpcpc/kirc.git#commit=3bb2b8d81000176ce9793de1983f33420b885673
+ source = skip-clean.patch
b2sums = SKIP
+ b2sums = 6c909b297b1c7d397d64f5c33332b16de8d2a166997b7467332de9e9b08e6159aff49e94a820790f482700c58174b7cd715c2eec2f313438cd38f1093e393655
pkgname = kirc
diff --git a/PKGBUILD b/PKGBUILD
index b03bef261d8d..df7391eaa26d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,21 @@
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=kirc
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=1
-pkgdesc="A tiny IRC client written in POSIX C99"
+pkgdesc='A tiny IRC client written in POSIX C99'
arch=('x86_64')
-url="https://github.com/mcpcpc/kirc"
+url='https://github.com/mcpcpc/kirc'
license=('MIT')
depends=('glibc')
makedepends=('git')
-_commit='851eed53dd3f251c6d85bd43325ccbe658f39a4d'
-source=("$pkgname::git+$url.git#commit=$_commit")
-b2sums=('SKIP')
+_commit='3bb2b8d81000176ce9793de1983f33420b885673'
+source=(
+ "$pkgname::git+$url.git#commit=$_commit"
+ 'skip-clean.patch'
+)
+b2sums=('SKIP'
+ '6c909b297b1c7d397d64f5c33332b16de8d2a166997b7467332de9e9b08e6159aff49e94a820790f482700c58174b7cd715c2eec2f313438cd38f1093e393655')
pkgver() {
cd "$pkgname"
@@ -19,6 +23,14 @@ pkgver() {
git describe --tags
}
+prepare() {
+ cd "$pkgname"
+
+ # removes the binary when `make install` is invocated due to `clean`
+ # being part of `all`
+ patch -p1 -i "$srcdir/skip-clean.patch"
+}
+
build() {
cd "$pkgname"
diff --git a/skip-clean.patch b/skip-clean.patch
new file mode 100644
index 000000000000..7848822bedfc
--- /dev/null
+++ b/skip-clean.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -7,7 +7,7 @@ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/share/man
+
+ all: clean kirc
+-install: all
++install:
+ mkdir -p $(DESTDIR)$(BINDIR)
+ mkdir -p $(DESTDIR)$(MANDIR)/man1
+ cp -f kirc $(DESTDIR)$(BINDIR)