summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2015-08-24 21:21:48 -0400
committerbrent s2015-08-24 21:21:48 -0400
commit346420759d06355beb1ffe4abe567397f786b662 (patch)
tree7a099d11243702f7531012cf00f19524f9851b1d
downloadaur-346420759d06355beb1ffe4abe567397f786b662.tar.gz
initial import from AUR3
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD74
-rw-r--r--kismet.changelog29
-rw-r--r--kismet.install34
4 files changed, 171 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..069335f1421f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = kismet-allplugins
+ pkgdesc = 802.11 layer2 wireless network detector, sniffer, and intrusion detection system(all plugins enabled)
+ pkgver = 2013_03_R1b
+ pkgrel = 2
+ url = http://www.kismetwireless.net/
+ install = kismet.install
+ changelog = kismet.changelog
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpcap
+ depends = pcre
+ depends = bluez-libs
+ depends = libcap
+ optdepends = gpsd: log coordinates of detected networks
+ optdepends = wireshark-cli: provide OUI files used to determine device manufacturer
+ optdepends = wireshark-cli: mergecap, to merge multiple capture files
+ optdepends = sox: provide the default kismet sound playback binary
+ optdepends = festival: text-to-speech support
+ optdepends = flite: alternative/lightweight text-to-speech support
+ optdepends = ruby: ruby interface
+ provides = kismet
+ conflicts = kismet
+ conflicts = kismet-svn
+ conflicts = kismet-ptw
+ backup = etc/kismet.conf
+ backup = etc/kismet_drone.conf
+ source = http://www.kismetwireless.net/code/kismet-2013-03-R1b.tar.gz
+ source = http://www.kismetwireless.net/code/kismet-2013-03-R1b.tar.gz.asc
+ md5sums = 6cdcd78baf2e15edbe8a9de3c5493f02
+ md5sums = SKIP
+
+pkgname = kismet-allplugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f70fdebebab0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# $Id: PKGBUILD 187862 2013-06-07 09:24:58Z tomegun $
+# Maintainer: GI_Jack <iamjacksemail@hackermail.com>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Jason Chu <jason@archlinux.org>
+# Contributor: Juergen Hoetzel <jason@archlinux.org>
+
+#compiled and included are the AutoWEP and PTW plugins not compiled by default
+pkgname=kismet-allplugins
+_pkgname=kismet
+pkgver=2013_03_R1b
+_realver="${pkgver//_/-}"
+pkgrel=2
+pkgdesc="802.11 layer2 wireless network detector, sniffer, and intrusion detection system(all plugins enabled)"
+arch=('i686' 'x86_64')
+url="http://www.kismetwireless.net/"
+license=('GPL')
+conflicts=('kismet' 'kismet-svn' 'kismet-ptw')
+provides=('kismet')
+depends=('libpcap' 'pcre' 'bluez-libs' 'libcap')
+optdepends=('gpsd: log coordinates of detected networks'
+ 'wireshark-cli: provide OUI files used to determine device manufacturer'
+ 'wireshark-cli: mergecap, to merge multiple capture files'
+ 'sox: provide the default kismet sound playback binary'
+ 'festival: text-to-speech support'
+ 'flite: alternative/lightweight text-to-speech support'
+ 'ruby: ruby interface')
+backup=('etc/kismet.conf' 'etc/kismet_drone.conf')
+install=kismet.install
+changelog=kismet.changelog
+source=("http://www.kismetwireless.net/code/${_pkgname}-${_realver}.tar.gz"{,.asc})
+md5sums=('6cdcd78baf2e15edbe8a9de3c5493f02'
+ 'SKIP')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${_realver}"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+ make dep
+ make
+
+ # Include plugins bundled with kismet
+ make plugins
+
+ cd restricted-plugin-ptw/
+ KIS_SRC_DIR="${srcdir}/${_pkgname}-${_realver}" make ||return 1
+ cd ..
+ cd restricted-plugin-autowep/
+ KIS_SRC_DIR="${srcdir}/${_pkgname}-${_realver}" make ||return 1
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${_realver}"
+
+ # Install kismet
+ make DESTDIR="$pkgdir" install
+
+ # Install plugins
+ make plugins-install DESTDIR="$pkgdir"
+
+ #install the PTR plugin
+ cd restricted-plugin-ptw/
+ KIS_SRC_DIR="${srcdir}/${_pkgname}-${_realver}" KIS_DEST_DIR="$pkgdir" DESTDIR="$KIS_DEST_DIR" make install || return 1
+ cd ..
+ cd restricted-plugin-autowep/
+ KIS_SRC_DIR="${srcdir}/${_pkgname}-${_realver}" KIS_DEST_DIR="$pkgdir" DESTDIR="$KIS_DEST_DIR" make install || return 1
+ cd ..
+ # the README is very comprehensive, a good idea to include it
+ install -D -m 644 "${srcdir}/kismet-${_realver}/README" "${pkgdir}/usr/share/kismet/README"
+
+ # Our own suid-install, first half (see kismet.install)
+ install -o "root" -g "root" -m 4550 kismet_capture "${pkgdir}/usr/bin/"
+}
diff --git a/kismet.changelog b/kismet.changelog
new file mode 100644
index 000000000000..3078d0625c35
--- /dev/null
+++ b/kismet.changelog
@@ -0,0 +1,29 @@
+2012-02-10 Eric BĂ©langer <eric@archlinux.org>
+ * Change libnl depends to libnl1
+
+2010-05-07 Angel Velasquez <angvp@archlinux.org>
+ * ChangeLog added
+
+ * Removed old patches from SVN
+
+ * Applied changes from FS#15746 thanks to people who worked on it.
+
+ * Files that are no longer shipped and so should not be backed up:
+ backup=('etc/ap_manuf' 'etc/client_manuf' 'etc/kismet_ui.conf')
+
+ * No longer needed; gpsmap is deprecated and being replaced with a tile-based
+ mapper, as of yet incomplete
+ optdepends=('perl-libwww: fetch maps for gpsmap')
+
+ * Configuration has completely changed, no longer containing
+ references to either prism2 or wlanng
+ sed -i 's/prism2/wlanng/g' conf/kismet.conf
+
+ * Ownership of man pages now defaults to "root" if the group "man" does not exist
+ chown root:root "$pkgdir"/usr/share/man/man{1,5}/*
+
+ * Dependencies no longer needed
+ depends=('gmp' 'imagemagick' 'dbus' 'libjpeg>=7')
+
+ * Options no longer needed
+ options=('!makeflags')
diff --git a/kismet.install b/kismet.install
new file mode 100644
index 000000000000..0bc806034937
--- /dev/null
+++ b/kismet.install
@@ -0,0 +1,34 @@
+## arg 1: the new package version
+post_install() {
+ post_upgrade
+
+ cat << EOP
+ If you have not done so already, read the README file and the FAQ file.
+ You MUST edit /etc/kismet.conf and configure Kismet for your system, or
+ it will NOT run properly!"
+
+ Kismet has been installed with a SUID ROOT CAPTURE HELPER executeable by
+ users in the group ' kismet '. This WILL ALLOW USERS IN THIS GROUP
+ TO ALTER YOUR NETWORK INTERACE STATES, but is more secure than running
+ all of Kismet as root. ONLY users in this group will be able to
+ run Kismet and capture from physical network devices.
+EOP
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ # Add the group needed to use the limited-functionality binary "kismet_capture"
+ # Change group ownership of "kismet_capture" to this new group
+ # Preserve the file mode bits of "kismet_capture"
+ getent group "kismet" &>/dev/null || /usr/sbin/groupadd -r -g 315 kismet &>/dev/null
+ chown root:kismet "/usr/bin/kismet_capture"
+ chmod 4550 "/usr/bin/kismet_capture"
+}
+
+## arg 1: the old package version
+post_remove() {
+ getent group "kismet" &>/dev/null && /usr/sbin/groupdel kismet &>/dev/null
+}
+
+# vim:set ts=2 sw=2 et: