summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortechge2017-12-09 16:44:49 +0100
committertechge2017-12-09 16:44:49 +0100
commit5098041947b7215698d52b92d9c0fd36d53c0407 (patch)
tree020b4f21e5946e0e567ef35aa8aeef2ff5f3cfa3
downloadaur-5098041947b7215698d52b92d9c0fd36d53c0407.tar.gz
Init
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD30
-rw-r--r--kismet.install26
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03dcc987d441
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = kismet-git
+ pkgdesc = Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1
+ pkgver = 2017120
+ pkgrel = 1
+ url = https://www.kismetwireless.net/
+ install = kismet.install
+ arch = x86_64
+ license = GPL
+ depends = libmicrohttpd
+ depends = libelf
+ depends = libpcap
+ depends = libnm
+ optdepends = hackrf: use with HackRF compatible software defined radio (SDR)
+ conflicts = kismet
+ backup = etc/kismet/kismet.conf
+ backup = etc/kismet/kismet_alerts.conf
+ backup = etc/kismet/kismet_httpd.conf
+ backup = etc/kismet/kismet_logging.conf
+ backup = etc/kismet/kismet_memory.conf
+ backup = etc/kismet/kismet_storage.conf
+ source = https://github.com/kismetwireless/kismet/archive/master.zip
+ md5sums = SKIP
+
+pkgname = kismet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63f3cc541a6b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexander Paetzelt <techge+arch [ät] posteo [do] net>
+pkgname=kismet-git
+pkgver=2017120
+pkgrel=1
+pkgdesc="Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1"
+arch=('x86_64')
+url="https://www.kismetwireless.net/"
+license=('GPL')
+depends=('libmicrohttpd' 'libelf' 'libpcap' 'libnm')
+optdepends=('hackrf: use with HackRF compatible software defined radio (SDR)')
+conflicts=('kismet')
+backup=('etc/kismet/kismet.conf' 'etc/kismet/kismet_alerts.conf' 'etc/kismet/kismet_httpd.conf' 'etc/kismet/kismet_logging.conf' 'etc/kismet/kismet_memory.conf' 'etc/kismet/kismet_storage.conf')
+install=kismet.install
+source=("https://github.com/kismetwireless/kismet/archive/master.zip")
+md5sums=('SKIP')
+
+build() {
+ cd "kismet-master"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/kismet
+ make
+}
+
+package() {
+ cd "kismet-master"
+ make DESTDIR="$pkgdir/" install
+ mkdir -p ${pkgdir}/usr/bin/kismet_capture_tools/
+ install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/kismet_capture_tools/"
+ install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/kismet_capture_tools/"
+}
diff --git a/kismet.install b/kismet.install
new file mode 100644
index 000000000000..45d902a16856
--- /dev/null
+++ b/kismet.install
@@ -0,0 +1,26 @@
+post_install() {
+ post_upgrade
+
+ cat << EOP
+ If you have not done so already, read the README file and the FAQ file. Additional
+ documentation is in the /usr/share/docs/ directory. You MUST edit
+ /etc/kismet/kismet.conf and configure Kismet for your system, or it will NOT run
+ properly!
+
+ Kismet has been installed with a SUID ROOT CAPTURE HELPER executeable by
+ users in the group 'kismet'. This WILL ALLOW USERS IN THIS GROUP
+ TO ALTER YOUR NETWORK INTERFACE STATES, but is more secure than running
+ all of Kismet as root. ONLY users in this group will be able to
+ run Kismet and capture from physical network devices.
+
+ Use 'sudo usermod -a -G kismet foouser' to add yourself to the kismet
+ group. You will need to log out and back in before your user will have access.
+ Check the output of the 'groups' command to make sure your user has the proper group!
+
+EOP
+}
+
+post_upgrade() {
+ # Add the group needed to use the limited-functionality binary "kismet_capture"
+ getent group "kismet" &>/dev/null || /usr/sbin/groupadd -r -g 315 kismet &>/dev/null
+}