summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortechge2017-12-10 19:48:32 +0100
committertechge2017-12-10 19:48:32 +0100
commit5dc935115e442be6be4ef5633d6a475c02b6b1e6 (patch)
treed14513b85badd0e02bc73d2d632b9d12d0afa4a6
parentcf4a98feac2388c173eb8963fad47c2603f42a4f (diff)
downloadaur-5dc935115e442be6be4ef5633d6a475c02b6b1e6.tar.gz
Retabbing and adding dev-docs
-rw-r--r--PKGBUILD19
-rw-r--r--kismet.install2
2 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e033d624109..74ad9d52fa82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Alexander Paetzelt <techge+arch [ät] posteo [do] net>
pkgname=kismet-git
-pkgver=20171209
+pkgver=20171210
pkgrel=1
pkgdesc="Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1"
arch=('x86_64')
@@ -15,16 +15,23 @@ source=("https://github.com/kismetwireless/kismet/archive/master.zip")
md5sums=('SKIP')
build() {
- cd "kismet-master"
- ./configure --prefix=/usr \
+ cd "kismet-master"
+ ./configure --prefix=/usr \
--sysconfdir=/etc/kismet
- make
+ make
}
package() {
- cd "kismet-master"
- make DESTDIR="$pkgdir/" install
+ cd "kismet-master"
+ make DESTDIR="$pkgdir/" install
+
+ # install capture_tools setuid so that kismet can started as user and still
+ # network device can get handled by capture tools
mkdir -p ${pkgdir}/usr/bin/kismet_capture_tools/
install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/kismet_capture_tools/"
install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/kismet_capture_tools/"
+
+ # include new docs in /usr/share/doc/
+ mkdir -p ${pkgdir}/usr/share/doc/$pkgname/
+ install -Dm 644 docs/dev/* "$pkgdir/usr/share/doc/$pkgname/"
}
diff --git a/kismet.install b/kismet.install
index 45d902a16856..405541f08122 100644
--- a/kismet.install
+++ b/kismet.install
@@ -3,7 +3,7 @@ post_install() {
cat << EOP
If you have not done so already, read the README file and the FAQ file. Additional
- documentation is in the /usr/share/docs/ directory. You MUST edit
+ documentation is in the /usr/share/doc/kismet-git/ directory. You MUST edit
/etc/kismet/kismet.conf and configure Kismet for your system, or it will NOT run
properly!