summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortechge2018-03-18 15:08:37 +0100
committertechge2018-03-18 15:12:13 +0100
commitf7f86d5793440dda847705143bdd68b53545f53a (patch)
tree813bc0d167573f72e4cb722ffb4373aa47a17576
parentbd4ed5b3e6a7506d721e43558618a96b801d8910 (diff)
downloadaur-f7f86d5793440dda847705143bdd68b53545f53a.tar.gz
New deps added and using sysusers.d for group creation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
-rw-r--r--kismet-git-sysusers.conf1
-rw-r--r--kismet.install10
4 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6487da53e3f..1886f330ea9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kismet-git
pkgdesc = Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1
- pkgver = 20171210
+ pkgver = 20180318
pkgrel = 1
url = https://www.kismetwireless.net/
install = kismet.install
@@ -10,6 +10,8 @@ pkgbase = kismet-git
depends = libelf
depends = libpcap
depends = libnm
+ depends = protobuf
+ depends = protobuf-c
optdepends = hackrf: use with HackRF compatible software defined radio (SDR)
conflicts = kismet
backup = etc/kismet/kismet.conf
diff --git a/PKGBUILD b/PKGBUILD
index 74ad9d52fa82..44ef3575e171 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Alexander Paetzelt <techge+arch [ät] posteo [do] net>
pkgname=kismet-git
-pkgver=20171210
+pkgver=20180318
pkgrel=1
pkgdesc="Current development version based on git repo, many crucial changes since official stable Release 2017_07_R1-1"
arch=('x86_64')
url="https://www.kismetwireless.net/"
license=('GPL')
-depends=('libmicrohttpd' 'libelf' 'libpcap' 'libnm')
+depends=('libmicrohttpd' 'libelf' 'libpcap' 'libnm' 'protobuf' 'protobuf-c')
optdepends=('hackrf: use with HackRF compatible software defined radio (SDR)')
conflicts=('kismet')
backup=('etc/kismet/kismet.conf' 'etc/kismet/kismet_alerts.conf' 'etc/kismet/kismet_httpd.conf' 'etc/kismet/kismet_logging.conf' 'etc/kismet/kismet_memory.conf' 'etc/kismet/kismet_storage.conf')
@@ -24,14 +24,17 @@ build() {
package() {
cd "kismet-master"
make DESTDIR="$pkgdir/" install
-
- # install capture_tools setuid so that kismet can started as user and still
+
+ # install capture_tools setuid so that kismet can started as user and
# network device can get handled by capture tools
- mkdir -p ${pkgdir}/usr/bin/kismet_capture_tools/
- install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/kismet_capture_tools/"
- install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/kismet_capture_tools/"
+ install -o root -g 315 -m 4550 capture_linux_wifi/kismet_cap_linux_wifi "${pkgdir}/usr/bin/"
+ install -o root -g 315 -m 4550 capture_linux_bluetooth/kismet_cap_linux_bluetooth "${pkgdir}/usr/bin/"
# include new docs in /usr/share/doc/
mkdir -p ${pkgdir}/usr/share/doc/$pkgname/
install -Dm 644 docs/dev/* "$pkgdir/usr/share/doc/$pkgname/"
+
+ # create group kismet via sysusers
+ cd ../..
+ install -vDm 644 "${pkgname}-sysusers.conf" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
}
diff --git a/kismet-git-sysusers.conf b/kismet-git-sysusers.conf
new file mode 100644
index 000000000000..85fc087dce76
--- /dev/null
+++ b/kismet-git-sysusers.conf
@@ -0,0 +1 @@
+u kismet 315 "Kismet users"
diff --git a/kismet.install b/kismet.install
index 405541f08122..daaf18c8daa3 100644
--- a/kismet.install
+++ b/kismet.install
@@ -1,9 +1,8 @@
post_install() {
- post_upgrade
-
cat << EOP
+
If you have not done so already, read the README file and the FAQ file. Additional
- documentation is in the /usr/share/doc/kismet-git/ directory. You MUST edit
+ documentation is in the /usr/share/docs/ directory. You MUST edit
/etc/kismet/kismet.conf and configure Kismet for your system, or it will NOT run
properly!
@@ -19,8 +18,3 @@ post_install() {
EOP
}
-
-post_upgrade() {
- # Add the group needed to use the limited-functionality binary "kismet_capture"
- getent group "kismet" &>/dev/null || /usr/sbin/groupadd -r -g 315 kismet &>/dev/null
-}