summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Lobdell2018-11-14 13:06:34 -0700
committerJohn Lobdell2018-11-14 13:06:34 -0700
commit83269660d0452af52917afc9b62c36fe104fe227 (patch)
tree671f74f8296317d1391946ef1eccfa7f59a19ee9
downloadaur-83269660d0452af52917afc9b62c36fe104fe227.tar.gz
add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbd67b5b65ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kismet-plugin-ubertooth
+ pkgdesc = Ubertooth plugin for Kismet
+ pkgver = 2018.08.R1
+ pkgrel = 1
+ url = http://sourceforge.net/projects/ubertooth/
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = ubertooth
+ depends = kismet
+ source = https://github.com/greatscottgadgets/ubertooth/releases/download/2018-08-R1/ubertooth-2018-08-R1.tar.xz
+ source = https://www.kismetwireless.net/code/kismet-2016-07-R1.tar.xz
+ md5sums = 41a5c192c1f0b5df0516f4abd08ac995
+ md5sums = 7fa6e86c5078a0e7d91fc9bf954c5107
+
+pkgname = kismet-plugin-ubertooth
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecc5b08c020f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=kismet-plugin-ubertooth
+pkgver=2018.08.R1
+pkgrel=1
+pkgdesc="Ubertooth plugin for Kismet"
+url="http://sourceforge.net/projects/ubertooth/"
+arch=('x86_64' 'i686')
+license=('GPL')
+depends=('ubertooth' 'kismet')
+source=("https://github.com/greatscottgadgets/ubertooth/releases/download/2018-08-R1/ubertooth-2018-08-R1.tar.xz"
+ "https://www.kismetwireless.net/code/kismet-2016-07-R1.tar.xz")
+md5sums=('41a5c192c1f0b5df0516f4abd08ac995'
+ '7fa6e86c5078a0e7d91fc9bf954c5107')
+
+build() {
+ cd "${srcdir}/kismet-2016-07-R1"
+ ./configure prefix="${pkgdir}/usr"
+ cd "${srcdir}/ubertooth-2018-08-R1/host/kismet/plugin-ubertooth"
+ KIS_SRC_DIR="${srcdir}/kismet-2016-07-R1" UBERTOOTH_INC_DIR="${srcdir}/ubertooth-2018-08-R1/host/libubertooth/src" make
+}
+
+package() {
+ cd "${srcdir}/ubertooth-2018-08-R1/host/kismet/plugin-ubertooth"
+ KIS_SRC_DIR="${srcdir}/kismet-2016-07-R1" UBERTOOTH_INC_DIR="${srcdir}/ubertooth-2018-08-R1/host/libubertooth/src" make install
+}