summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Owens2015-10-30 17:26:58 -0500
committerRyan Owens2015-10-30 17:26:58 -0500
commit6cb61322d5095c521084d1c9c2053d7ad9c8bd1c (patch)
treeb66a4c7a67da3d5a255c7bf8ee07168812cbdb29
downloadaur-6cb61322d5095c521084d1c9c2053d7ad9c8bd1c.tar.gz
Initial Commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD49
-rw-r--r--kiss.desktop7
-rw-r--r--kiss.pngbin0 -> 134227 bytes
-rwxr-xr-xkiss.sh3
5 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..685c5cf4e5ca
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = kiss
+ pkgdesc = KIPR's Instructional Software System
+ pkgver = 5.1.3
+ pkgrel = 1
+ url = https://github.com/kipr/pcompiler
+ arch = any
+ license = GPL3
+ depends = cmake>=2.8.12
+ depends = qt5-quick1
+ depends = qt5-base
+ depends = libkar
+ depends = pcompiler
+ depends = libkovanserial
+ depends = qscintilla-qt5
+ depends = qtwebkit
+ provides = pcompiler
+ source = https://github.com/kipr/kiss/archive/5.1.3.tar.gz
+ source = kiss.desktop
+ source = kiss.png
+ source = kiss.sh
+ sha256sums = 65f2b2e223c75acc6d79df4b2f778c2ceeafb864819e595a5c99ed2ac315e659
+ sha256sums = 20becea94867cf5d9ce7c389544734ac192369d6f4b8d3d8504960e530870690
+ sha256sums = 02252493c14b7b2b6e7ae74ec972a2dd305c476b1edcfce96ce2acd60e9e3f03
+ sha256sums = bcadce53b90b17fbc3b3a24e01f58f43920ec9c9b190c755170b375d5e992892
+
+pkgname = kiss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4ce9e0fb848
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Ryan Owens <RyanOwens[at]linux[dot]com>
+
+pkgname=kiss
+pkgver=5.1.3
+pkgrel=1
+pkgdesc="KIPR's Instructional Software System"
+arch=('any')
+url="https://github.com/kipr/pcompiler"
+license=('GPL3')
+depends=('cmake>=2.8.12' 'qt5-quick1' 'qt5-base' 'libkar' 'pcompiler' 'libkovanserial' 'qscintilla-qt5' 'qtwebkit')
+provides=('pcompiler')
+source=("https://github.com/kipr/kiss/archive/5.1.3.tar.gz"
+ "kiss.desktop"
+ "kiss.png"
+ "kiss.sh")
+sha256sums=('65f2b2e223c75acc6d79df4b2f778c2ceeafb864819e595a5c99ed2ac315e659'
+ '20becea94867cf5d9ce7c389544734ac192369d6f4b8d3d8504960e530870690'
+ '02252493c14b7b2b6e7ae74ec972a2dd305c476b1edcfce96ce2acd60e9e3f03'
+ 'bcadce53b90b17fbc3b3a24e01f58f43920ec9c9b190c755170b375d5e992892')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ sed -i 's/target_link_libraries(KISS qscintilla2 pcompiler kar kovanserial ${EXTRA_LIBS})/target_link_libraries(KISS qt5scintilla2 pcompiler kar kovanserial ${EXTRA_LIBS})/' CMakeLists.txt
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}/build
+ make install
+ cd ..
+ mkdir -p ${pkgdir}/opt/${pkgname}/
+ #mkdir -p ${pkgdir}/usr/share/icons/
+ #mkdir -p ${pkgdir}/usr/share/applications/
+ #mkdir -p ${pkgdir}/usr/bin/
+
+ install -Dm644 ${srcdir}/kiss.desktop ${pkgdir}/usr/share/applications/kiss.desktop
+ install -Dm644 ${srcdir}/kiss.png ${pkgdir}/usr/share/icons/kiss.png
+ install -Dm555 ${srcdir}/kiss.sh ${pkgdir}/usr/bin/KISS
+
+ cd deploy
+ install -Dm555 ./KISS ${pkgdir}/opt/${pkgname}/KISS
+ #install -Dm555 ./KISS ${pkgdir}/usr/bin/KISS
+ install -dDm644 ./docs ${pkgdir}/opt/${pkgname}/docs
+ install -dDm644 ./locale ${pkgdir}/opt/${pkgname}/locale
+ install -dDm644 ./template_packs ${pkgdir}/opt/${pkgname}/template_packs
+}
diff --git a/kiss.desktop b/kiss.desktop
new file mode 100644
index 000000000000..c69b42faff12
--- /dev/null
+++ b/kiss.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=KISS IDE
+Exec=/usr/bin/KISS
+Icon=/usr/share/icons/kiss.png
+Categrories=Development;
+name[en_US]=kiss.desktop
diff --git a/kiss.png b/kiss.png
new file mode 100644
index 000000000000..9fdd545769c0
--- /dev/null
+++ b/kiss.png
Binary files differ
diff --git a/kiss.sh b/kiss.sh
new file mode 100755
index 000000000000..52d93eeb8355
--- /dev/null
+++ b/kiss.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/kiss
+./KISS