summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobinhuett2018-08-26 00:13:55 +0200
committerRobinhuett2018-08-26 00:13:55 +0200
commitbc9f726d82083e06d0d7a93e96a64b8c8a535eb3 (patch)
tree205435d49457e1343509428b74c3ffb259629be6
downloadaur-bc9f726d82083e06d0d7a93e96a64b8c8a535eb3.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
-rw-r--r--kiss-gui.desktop8
-rw-r--r--kiss-gui.sh3
5 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3ec1c4a3b17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = kiss-gui
+ pkgdesc = The KISS GUI is the crossplatform configuration tool for the Flyduino flight control system like the KISSfc, KISScc and KISSfcV2F7
+ pkgver = 2.0.9
+ pkgrel = 1
+ url = https://github.com/flyduino/kissfc-chrome-gui
+ arch = x86_64
+ options = !strip
+ source = https://github.com/flyduino/kissfc-chrome-gui/releases/download/2.0.9/KISS-GUI_2.0.9-master_d6ff322-linux64.zip
+ source = https://raw.githubusercontent.com/flyduino/kissfc-chrome-gui/master/images/icon_128.png
+ source = kiss-gui.sh
+ source = kiss-gui.desktop
+ sha512sums = fa00afd475131619e22220e3a206896cfdf7d7b9c203fbce9bafad435d5505618441db1f7b07b98eff5b55250fa6b177d414be08529b8b4f695832d955d65a28
+ sha512sums = 36af702cf64bc0606eaf01febd3ed7db47e327bfb68f10f23f65d36b9a9482038e22149711d5b1fbbeabc1a6fcef9de25e971aa7f67b475983fd9aa3c57ca22f
+ sha512sums = 7aaaeb1688560a0874e69455ce25f273fa03aa5ad3a41116f4a71cde49ccfe334c05c955384e3624f5a7fca1300461eec41540cd05a7d61a3343dac09b576497
+ sha512sums = 5a43483c365a1b1134bdd176be481a0400d3807b270cf0a31a575d5a7b0de167db6d1cd182ee9443cc0c86c77fbe14bb66bb1147c230f994aab36540687536ae
+
+pkgname = kiss-gui \ No newline at end of file
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..23ddc7ac112d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/*
+src/*
+*.xz
+*.gz
+*.zip \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a7e8624a6b39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Robinhuett <aur at tripp dot xyz>
+
+pkgname=kiss-gui
+arch=(x86_64)
+pkgver=2.0.9
+pkgrel=1
+_commit=d6ff322
+pkgdesc="The KISS GUI is the crossplatform configuration tool for the Flyduino flight control system like the KISSfc, KISScc and KISSfcV2F7"
+url="https://github.com/flyduino/kissfc-chrome-gui"
+
+source=("$url/releases/download/$pkgver/KISS-GUI_$pkgver-master_$_commit-linux64.zip"
+ "https://raw.githubusercontent.com/flyduino/kissfc-chrome-gui/master/images/icon_128.png"
+ "$pkgname.sh"
+ "$pkgname.desktop")
+sha512sums=('fa00afd475131619e22220e3a206896cfdf7d7b9c203fbce9bafad435d5505618441db1f7b07b98eff5b55250fa6b177d414be08529b8b4f695832d955d65a28'
+ '36af702cf64bc0606eaf01febd3ed7db47e327bfb68f10f23f65d36b9a9482038e22149711d5b1fbbeabc1a6fcef9de25e971aa7f67b475983fd9aa3c57ca22f'
+ '7aaaeb1688560a0874e69455ce25f273fa03aa5ad3a41116f4a71cde49ccfe334c05c955384e3624f5a7fca1300461eec41540cd05a7d61a3343dac09b576497'
+ '5a43483c365a1b1134bdd176be481a0400d3807b270cf0a31a575d5a7b0de167db6d1cd182ee9443cc0c86c77fbe14bb66bb1147c230f994aab36540687536ae')
+options=(!strip)
+
+package() {
+ cd KISS-GUI
+ install -d "$pkgdir/usr/share/$pkgname/"
+ cp -a * "$pkgdir/usr/share/$pkgname/"
+
+ install -D "$srcdir/icon_128.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+
+ install -D "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ install -d "$pkgdir/usr/bin/"
+ install -Dm 755 "$srcdir/$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+}
+
diff --git a/kiss-gui.desktop b/kiss-gui.desktop
new file mode 100644
index 000000000000..4d5d37750f96
--- /dev/null
+++ b/kiss-gui.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=KISS GUI
+Comment=Crossplatform configuration tool for the KISS flight control system
+Exec=kiss-gui
+Icon=kiss-gui
+Terminal=false
+Type=Application
+Categories=Utility \ No newline at end of file
diff --git a/kiss-gui.sh b/kiss-gui.sh
new file mode 100644
index 000000000000..a22a7db7f45d
--- /dev/null
+++ b/kiss-gui.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+/usr/share/kiss-gui/kiss-gui