summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmos Wenger2018-12-17 19:03:38 +0100
committerAmos Wenger2018-12-17 19:03:38 +0100
commitbe9efbaf609865c8ba56e461a091ae7a06722295 (patch)
treec19b3070144ee7bb924a078d77ce1806078b21b4
parent4fde6d6042ce9070b654f3ca3fcb1b393d2c7062 (diff)
downloadaur-be9efbaf609865c8ba56e461a091ae7a06722295.tar.gz
Increase epoch, use source array to download kitch-setup instead
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 84aedbf2dd4e..86cb40854bfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = kitch
pkgdesc = The best way to play itch.io games.
pkgver = 1.14.0
- pkgrel = 2
+ pkgrel = 3
+ epoch = 1
url = https://github.com/itchio/kitch
install = kitch.install
arch = i686
@@ -20,7 +21,9 @@ pkgbase = kitch
depends = gtk3
options = !strip
source = https://github.com/itchio/itch/archive/v25.4.0.tar.gz
+ source = kitch-setup::https://broth.itch.ovh/kitch-setup/linux-amd64/1.14.0/unpacked/default
sha256sums = e86c70044c7d02754c6e52fb428d1278678d729c77b8359b5d82198595da1351
+ sha256sums = 5e3c70c2c3594e44b7df204acb13684dae69575963c33797191c345e6076202d
pkgname = kitch
diff --git a/PKGBUILD b/PKGBUILD
index b461ada9bb3e..3402b5a7b1e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,8 @@
pkgname=kitch
pkgver=1.14.0
-pkgrel=2
+pkgrel=3
+epoch=1
pkgdesc="The best way to play itch.io games."
arch=('i686' 'x86_64')
@@ -18,12 +19,11 @@ install="kitch.install"
[ "$CARCH" = "i686" ] && _ITCH_ARCH=386;
[ "$CARCH" = "x86_64" ] && _ITCH_ARCH=amd64;
-source=("https://github.com/itchio/itch/archive/v25.4.0.tar.gz")
-sha256sums=('e86c70044c7d02754c6e52fb428d1278678d729c77b8359b5d82198595da1351')
-
-prepare() {
- curl --fail --location --output kitch-setup "https://broth.itch.ovh/kitch-setup/linux-${_ITCH_ARCH}/${pkgver}/unpacked/default"
-}
+source=(
+ "https://github.com/itchio/itch/archive/v25.4.0.tar.gz"
+ "kitch-setup::https://broth.itch.ovh/kitch-setup/linux-${_ITCH_ARCH}/${pkgver}/unpacked/default")
+sha256sums=('e86c70044c7d02754c6e52fb428d1278678d729c77b8359b5d82198595da1351'
+ '5e3c70c2c3594e44b7df204acb13684dae69575963c33797191c345e6076202d')
package() {
install -Dm755 kitch-setup "${pkgdir}/usr/bin/kitch-setup"