summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEgidio Caprino2023-05-29 15:30:16 +0200
committerEgidio Caprino2023-05-29 15:30:16 +0200
commit44de0d198f7983f4e26fd232a7ccdbdf8a301eec (patch)
tree436fe3313ca9663e0994dd00bd283f99cacbb3d2
downloadaur-44de0d198f7983f4e26fd232a7ccdbdf8a301eec.tar.gz
feat: first version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
-rw-r--r--kitchenowl.desktop8
-rw-r--r--kitchenowl.pngbin0 -> 6013 bytes
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fde555577837
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = kitchenowl
+ pkgdesc = KitchenOwl is a self-hosted grocery list and recipe manager.
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://github.com/TomBursch/kitchenowl
+ arch = x86_64
+ license = GPL3
+ source = kitchenowl.png
+ source = kitchenowl.desktop
+ source = kitchenowl-0.4.4.tar.gz::https://github.com/TomBursch/kitchenowl/releases/download/v0.4.4/kitchenowl_Linux.tar.gz
+ sha256sums = 06f7b7e317e1732feda0bce957af7bf7b8a797147d865951df21532cb949863b
+ sha256sums = 8ec1df01450010aefb23728c69b8ff6eb2d9ceae9e1e1464374c6f0ae36a30c1
+ sha256sums = 4fceaa89a54de1f63567268ccfcd10baecb50d162bd3272eddcb4ba72114ee52
+
+pkgname = kitchenowl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b1884e614eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname="kitchenowl"
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="KitchenOwl is a self-hosted grocery list and recipe manager."
+arch=("x86_64")
+url="https://github.com/TomBursch/kitchenowl"
+license=("GPL3")
+source=(
+ "kitchenowl.png"
+ "kitchenowl.desktop"
+ "${pkgname%}-${pkgver}.tar.gz::https://github.com/TomBursch/kitchenowl/releases/download/v${pkgver}/kitchenowl_Linux.tar.gz"
+)
+sha256sums=(
+ "06f7b7e317e1732feda0bce957af7bf7b8a797147d865951df21532cb949863b"
+ "8ec1df01450010aefb23728c69b8ff6eb2d9ceae9e1e1464374c6f0ae36a30c1"
+ "4fceaa89a54de1f63567268ccfcd10baecb50d162bd3272eddcb4ba72114ee52"
+)
+
+package() {
+ install -d "$pkgdir/opt/${pkgname}"
+ install -d "${pkgdir}/usr/bin"
+
+ cp -r "$srcdir/data" "$pkgdir/opt/${pkgname}/"
+ cp -r "$srcdir/lib" "$pkgdir/opt/${pkgname}/"
+ cp "$srcdir/kitchenowl" "$pkgdir/opt/${pkgname}/"
+
+ ln -s "$pkgdir/opt/${pkgname}/kitchenowl" "${pkgdir}/usr/bin/kitchenowl"
+ chmod +x "${pkgdir}/usr/bin/kitchenowl"
+ install -Dm644 "${srcdir}/kitchenowl.png" "${pkgdir}/usr/share/icons/kitchenowl.png"
+ install -Dm644 "${srcdir}/kitchenowl.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/kitchenowl.desktop b/kitchenowl.desktop
new file mode 100644
index 000000000000..efbe13ea9e9d
--- /dev/null
+++ b/kitchenowl.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=KitchenOwl
+GenericName=Grocery list and recipe manager
+Comment=KitchenOwl is a smart grocery list and recipe manager
+Exec=/usr/bin/kitchenowl
+Icon=kitchenowl
+Type=Application
+Categories=Utility
diff --git a/kitchenowl.png b/kitchenowl.png
new file mode 100644
index 000000000000..e589ca93b803
--- /dev/null
+++ b/kitchenowl.png
Binary files differ