summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimur Kiyivinski2016-07-08 00:49:21 +0800
committerTimur Kiyivinski2016-07-08 00:49:21 +0800
commit3348592c7a9a6b9157412b7c6345ecf3dff8aea3 (patch)
treea2f883cfa906512d32224cfa8c7a5c2b117c9776
downloadaur-3348592c7a9a6b9157412b7c6345ecf3dff8aea3.tar.gz
Initial AUR submission
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89178c2b745e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kitematic-git
+ pkgdesc = Visual Docker Container Management
+ pkgver = 2129.ece9cfa
+ pkgrel = 1
+ url = https://github.com/docker/kitematic
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = npm
+ makedepends = nodejs-grunt-cli
+ depends = docker
+ depends = nodejs
+ conflicts = kitematic
+ source = kitematic-git::git+https://github.com/docker/kitematic.git
+ sha256sums = SKIP
+
+pkgname = kitematic-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd2a99947ba3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Timur Kiyivinski <timur@linux.com>
+
+pkgname=kitematic-git
+pkgver=2129.ece9cfa
+pkgrel=1
+pkgdesc='Visual Docker Container Management'
+arch=('x86_64')
+url='https://github.com/docker/kitematic'
+license=('Apache')
+depends=('docker' 'nodejs')
+makedepends=('git' 'npm' 'nodejs-grunt-cli')
+conflicts=('kitematic')
+source=("$pkgname::git+https://github.com/docker/kitematic.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$pkgname"
+ npm install
+ grunt babel less copy:dev shell:linux_npm electron-packager:build
+}
+
+package() {
+ install -dm755 "$pkgdir"/{opt,usr/bin}
+ cp -R "$pkgname/dist/Kitematic-linux-x64/" "$pkgdir/opt/$pkgname"
+ ln -s "$pkgdir/opt/$pkgname/Kitematic" "$pkgdir/usr/bin/kitematic"
+}