summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornamedkitten2020-04-25 12:10:06 +0100
committernamedkitten2020-04-25 12:10:06 +0100
commitb802ecbf2dafa01cf9b6a4837d8dc774c1692b98 (patch)
tree30bbbe407cbc82d0bbf41c880668e0a408823128
downloadaur-b802ecbf2dafa01cf9b6a4837d8dc774c1692b98.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
-rwxr-xr-xupdate.sh6
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d47759489d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kittehplayer-git
+ pkgdesc = A Qt Video Player with many themes for YouTube, Niconico and RoosterTeeth
+ pkgver = 1
+ pkgrel = 1
+ arch = any
+ license = MPL2
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-svg
+ depends = qt5-declarative
+ depends = qt5-quickcontrols
+ depends = qt5-quickcontrols2
+ depends = qt5-graphicaleffects
+ depends = mpv
+ optdepends = ffmpegthumbnailer: playlist thumbnails support
+ optdepends = youtube-dl: for sites like YouTube and Dailymotion
+ source = git+https://github.com/NamedKitten/KittehPlayer
+ md5sums = SKIP
+
+pkgname = kittehplayer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c50c1b783a16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kitteh <namedkitten@gmail.com>
+pkgname=kittehplayer-git
+reponame=KittehPlayer
+pkgver=1
+pkgrel=1
+epoch=
+pkgdesc="A Qt Video Player with many themes for YouTube, Niconico and RoosterTeeth"
+arch=("any")
+url=""
+license=('MPL2')
+groups=()
+depends=(qt5-svg qt5-declarative qt5-quickcontrols qt5-quickcontrols2 qt5-graphicaleffects mpv)
+makedepends=(git cmake)
+optdepends=('ffmpegthumbnailer: playlist thumbnails support'
+ 'youtube-dl: for sites like YouTube and Dailymotion')
+source=("git+https://github.com/NamedKitten/KittehPlayer")
+md5sums=("SKIP")
+
+pkgver() {
+cat ${reponame}/version
+}
+
+build() {
+ if [ -d build ]; then
+ rm -rf build
+ fi
+ mkdir build
+ cd build
+ cmake ../${reponame} -DCMAKE_UNITY_BUILD=yes -DCMAKE_UNITY_BUILD_BATCH_SIZE=100 -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..1446a6f343e9
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+set -e
+makepkg -sc
+rm -rf src *.pkg.* KittehPlayer
+makepkg --printsrcinfo > .SRCINFO
+git add . && git commit -m "Update" && git push