summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-03-12 07:10:35 +0200
committerDimitris Kiziridis2020-03-12 07:10:35 +0200
commit5e5ec43d2fe2ffd2b7784c58f2d1ea289bd15d22 (patch)
tree556961aea469266983af492f8eb5e23be8aaa110
downloadaur-5e5ec43d2fe2ffd2b7784c58f2d1ea289bd15d22.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edc6d7e76f51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = kitti3
+ pkgdesc = Kitty drop-down service for i3wm
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/LandingEllipse/kitti3
+ arch = any
+ license = BSD3
+ depends = i3-wm
+ depends = kitty
+ depends = python>=3.6
+ depends = python-i3ipc
+ source = kitti3-0.2.4.tar.gz::https://github.com/LandingEllipse/kitti3/archive/v0.2.4.tar.gz
+ md5sums = f7c6b3032987d3a35a9776091fd9afa9
+
+pkgname = kitti3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..604eea4a1f98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=kitti3
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="Kitty drop-down service for i3wm"
+arch=('any')
+url="https://github.com/LandingEllipse/kitti3"
+license=('BSD3')
+depends=('i3-wm' 'kitty' 'python>=3.6' 'python-i3ipc')
+source=("$pkgname-$pkgver.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+md5sums=('f7c6b3032987d3a35a9776091fd9afa9')
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ cp "$pkgname-$pkgver"/src/kitti3/main.py ${pkgdir}/usr/bin/kitti3
+ chmod 755 ${pkgdir}/usr/bin/kitti3
+} \ No newline at end of file