summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2017-11-05 02:26:21 +0100
committerFabioLolix2017-11-05 02:26:21 +0100
commitdd25b509695f2f4b557386dd6b0f7ce00d5cf73f (patch)
treef660191ac08dae984d13393ef37899d75a5f5a54
downloadaur-dd25b509695f2f4b557386dd6b0f7ce00d5cf73f.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31b4a92fc2d9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = kitty
+ pkgdesc = A modern, hackable, featureful, OpenGL based terminal emulator
+ pkgver = 0.4.2
+ pkgrel = 1
+ url = https://github.com/kovidgoyal/kitty
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = pkg-config
+ makedepends = python-setuptools
+ depends = python3
+ depends = glew
+ depends = glfw-x11
+ depends = freetype2
+ depends = xorg-xdpyinfo
+ depends = xsel
+ depends = fontconfig
+ depends = libunistring
+ source = https://github.com/kovidgoyal/kitty/archive/v0.4.2.tar.gz
+ md5sums = a5c506d8cf13085fe589d459a8568657
+
+pkgname = kitty
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f6d65a88d04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Fabio Loli <loli_fabio@protonmail.com> -> https://github.com/FabioLolix
+# Contributor: Maximilian Kindshofer <maximilian@kindshofer.net>
+
+pkgname=kitty
+pkgver=0.4.2
+pkgrel=1
+pkgdesc="A modern, hackable, featureful, OpenGL based terminal emulator"
+arch=('i686' 'x86_64')
+url="https://github.com/kovidgoyal/kitty"
+license=('GPL3')
+depends=('python3' 'glew' 'glfw-x11' 'freetype2' 'xorg-xdpyinfo' 'xsel' 'fontconfig' 'libunistring')
+makedepends=('git' 'pkg-config' 'python-setuptools')
+source=("https://github.com/kovidgoyal/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('a5c506d8cf13085fe589d459a8568657')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python3 setup.py linux-package
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver/linux-package"
+ install -d $pkgdir/usr/{bin,lib,share}
+ cp -r bin/* $pkgdir/usr/bin
+ cp -r share/* $pkgdir/usr/share/
+ cp -r lib/* $pkgdir/usr/lib/
+
+ install -d ${pkgdir}/usr/share/pixmaps/
+ mv ${pkgdir}/usr/share/icons/hicolor/256x256/kitty.png ${pkgdir}/usr/share/pixmaps/kitty.png
+ rm -R ${pkgdir}/usr/share/icons
+}