summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2018-12-10 22:54:08 +0100
committerFabioLolix2018-12-10 22:54:08 +0100
commit14451cbf378ef15693e06b905ec52acf335424f4 (patch)
treea51d1469897153f6a706bf9da3be940513a33c2c
parentf5f0a59b2c55c63c75f58dbc6323d91d2829089f (diff)
downloadaur-14451cbf378ef15693e06b905ec52acf335424f4.tar.gz
Revision
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1a063e74bd8..25dee26e7896 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kitty-git
pkgdesc = A modern, hackable, featureful, OpenGL based terminal emulator
- pkgver = 0.11.0.r45.g49b065cb
+ pkgver = 0.13.1.r0.g1ba7b5f5
pkgrel = 1
url = https://github.com/kovidgoyal/kitty
arch = i686
@@ -22,11 +22,11 @@ pkgbase = kitty-git
depends = fontconfig
depends = wayland
depends = libx11
+ depends = libgl
optdepends = imagemagick: viewing images with icat
provides = kitty
conflicts = kitty
- conflicts = kitty-git
- source = kitty-git::git+https://github.com/kovidgoyal/kitty.git
+ source = git+https://github.com/kovidgoyal/kitty.git
md5sums = SKIP
pkgname = kitty-git
diff --git a/PKGBUILD b/PKGBUILD
index feb6bc4e92ec..17879a9706b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,27 @@
# Contributor: Maximilian Kindshofer <maximilian@kindshofer.net>
pkgname=kitty-git
-pkgver=0.11.0.r45.g49b065cb
+pkgver=0.13.1.r0.g1ba7b5f5
pkgrel=1
pkgdesc="A modern, hackable, featureful, OpenGL based terminal emulator"
-arch=('i686' 'x86_64')
+arch=(i686 x86_64)
url="https://github.com/kovidgoyal/kitty"
-license=('GPL3')
-depends=('python3' 'freetype2' 'fontconfig' 'wayland' 'libx11')
-makedepends=('git' 'python-setuptools' 'libxinerama' 'libxcursor' 'libxrandr' 'libxkbcommon' 'libxkbcommon-x11' 'glfw-x11' 'wayland-protocols' 'mesa' python-sphinx)
+license=(GPL3)
+depends=(python3 freetype2 fontconfig wayland libx11 libgl)
+makedepends=(git python-setuptools libxinerama libxcursor libxrandr libxkbcommon libxkbcommon-x11 glfw-x11 wayland-protocols mesa python-sphinx)
optdepends=('imagemagick: viewing images with icat')
-provides=('kitty')
-conflicts=('kitty' 'kitty-git')
-source=("${pkgname}::git+https://github.com/kovidgoyal/kitty.git")
+provides=(kitty)
+conflicts=(kitty)
+source=("git+https://github.com/kovidgoyal/kitty.git")
md5sums=('SKIP')
pkgver() {
- cd "${pkgname}"
+ cd "$srcdir/${pkgname/-git/}"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "$srcdir/${pkgname/-git/}"
python3 setup.py linux-package --prefix "${pkgdir}"/usr
}