summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaximilian2017-01-10 16:51:12 +0100
committermaximilian2017-01-10 16:51:12 +0100
commit53064f234458c5c018988f8c48bcf1d012df6c28 (patch)
treeb00e857c4545f80727f2f9377ddb6149e3b7ce0f
downloadaur-53064f234458c5c018988f8c48bcf1d012df6c28.tar.gz
Kitty Aur PKG
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bb12a958471
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = kitty-git
+ pkgdesc = A modern, hackable, featureful, OpenGL based terminal emulator
+ pkgver = r696.0d38a2e
+ pkgrel = 1
+ url = https://github.com/kovidgoyal/kitty
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = pkg-config
+ makedepends = python-setuptools
+ depends = python3
+ depends = glew
+ depends = glfw-x11
+ depends = freetype2
+ source = git+https://github.com/kovidgoyal/kitty.git
+ md5sums = SKIP
+
+pkgname = kitty-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..911b57cc179e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Maximilian Kindshofer <maximilian@kindshofer.net>
+pkgname=kitty-git
+pkgver=r696.0d38a2e
+pkgrel=1
+pkgdesc="A modern, hackable, featureful, OpenGL based terminal emulator" # you've missed pkgdesc which is neccessary
+arch=('i686' 'x86_64')
+url="https://github.com/kovidgoyal/kitty"
+license=('GPL3')
+depends=('python3' 'glew' 'glfw-x11' 'freetype2')
+makedepends=('git' 'pkg-config' 'python-setuptools')
+source=('git+https://github.com/kovidgoyal/kitty.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd kitty
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ }
+
+build() {
+ cd "$srcdir/kitty"
+ python3 setup.py linux-package
+ }
+
+package() {
+ cd "$srcdir/kitty/linux-package"
+ mkdir -p $pkgdir/usr/bin/
+ mkdir -p $pkgdir/usr/lib/
+ mkdir -p $pkgdir/usr/share
+ cp -r bin/* $pkgdir/usr/bin
+ cp -r share/* $pkgdir/usr/share/
+ cp -r lib/* $pkgdir/usr/lib/
+ }