summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMithicSpirit2024-04-14 23:19:49 -0400
committerMithicSpirit2024-04-14 23:19:49 -0400
commitbf5c3a94e87da196749eb0d37fcb771dc2d3d016 (patch)
tree711eabbcc8b132e59d0dca39c5deeb927b3883d6
parentecef6067b365d0f0e6fd6aa7fc604783ed6b8534 (diff)
downloadaur-bf5c3a94e87da196749eb0d37fcb771dc2d3d016.tar.gz
0.34.0.p1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--shade-transparency.patch2
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4dcb98a5469..5a68fc2821bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kitty-shade-transparency-patch
pkgdesc = Kitty terminal emulator with a patch to make shade characters semitransparent
- pkgver = 0.33.0.p1
+ pkgver = 0.34.0.p1
pkgrel = 1
url = https://github.com/kovidgoyal/kitty
arch = x86_64
@@ -24,13 +24,13 @@ pkgbase = kitty-shade-transparency-patch
depends = lcms2
depends = librsync
depends = xxhash
- source = kitty-0.33.0.tar.xz::https://github.com/kovidgoyal/kitty/releases/download/v0.33.0/kitty-0.33.0.tar.xz
- source = kitty-0.33.0.tar.xz.sig::https://github.com/kovidgoyal/kitty/releases/download/v0.33.0/kitty-0.33.0.tar.xz.sig
+ source = kitty-0.34.0.tar.xz::https://github.com/kovidgoyal/kitty/releases/download/v0.34.0/kitty-0.34.0.tar.xz
+ source = kitty-0.34.0.tar.xz.sig::https://github.com/kovidgoyal/kitty/releases/download/v0.34.0/kitty-0.34.0.tar.xz.sig
source = shade-transparency.patch
validpgpkeys = 3CE1780F78DD88DF45194FD706BC317B515ACE7C
- sha512sums = 5dad29e7ff0f83dd14138fd32ee3d556214251a5617ef9bd0c8a8b4032e26cf8973752d0b4221e06afd745ae4a12967fc1194f3d053b0e8451cb7ca97360fa35
+ sha512sums = 310084af59fb5832c9b87961d278601a8408fdcf4500083ffa5d4980ae600a2122a7477be23bfe0c374dec7955707894cb74cfd550ae577d66e39ed2e8b9c0f8
sha512sums = SKIP
- sha512sums = cfdc8251c45ca1e6bd55ac436d26b54cf06ff07d70a445b0a52fc9a8bb2301a56801e9dab7ad18e34bed2f6c4be08428249dec5e14deefd4e44aa4ef2bc3beb6
+ sha512sums = 0d20f72a4a864e0d0da3e3b01e8ff9cf5f702cd1b6997400316b3b2426a4eb87a46879c8b9ea1662a7de1d6dbc0e3995b259f33c92bb34d3a80dd14344ffccae
pkgname = kitty-shade-transparency-patch
depends = python3
diff --git a/PKGBUILD b/PKGBUILD
index dcbe34a3f0d1..0db02cd081c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Maximilian Kindshofer <maximilian@kindshofer.net>
_pkgbase=kitty
-_pkgver=0.33.0
+_pkgver=0.34.0
_patchver=1
_patchname=shade-transparency
_suffix="${_patchname}-patch"
@@ -25,9 +25,9 @@ makedepends=('libxinerama' 'libxcursor' 'libxrandr' 'wayland-protocols' 'go' 'si
source=("${_pkgbase}-${_pkgver}.tar.xz::https://github.com/kovidgoyal/${_pkgbase}/releases/download/v${_pkgver}/${_pkgbase}-${_pkgver}.tar.xz"
"${_pkgbase}-${_pkgver}.tar.xz.sig::https://github.com/kovidgoyal/${_pkgbase}/releases/download/v${_pkgver}/${_pkgbase}-${_pkgver}.tar.xz.sig"
"${_patchname}.patch")
-sha512sums=('5dad29e7ff0f83dd14138fd32ee3d556214251a5617ef9bd0c8a8b4032e26cf8973752d0b4221e06afd745ae4a12967fc1194f3d053b0e8451cb7ca97360fa35'
+sha512sums=('310084af59fb5832c9b87961d278601a8408fdcf4500083ffa5d4980ae600a2122a7477be23bfe0c374dec7955707894cb74cfd550ae577d66e39ed2e8b9c0f8'
'SKIP'
- 'cfdc8251c45ca1e6bd55ac436d26b54cf06ff07d70a445b0a52fc9a8bb2301a56801e9dab7ad18e34bed2f6c4be08428249dec5e14deefd4e44aa4ef2bc3beb6')
+ '0d20f72a4a864e0d0da3e3b01e8ff9cf5f702cd1b6997400316b3b2426a4eb87a46879c8b9ea1662a7de1d6dbc0e3995b259f33c92bb34d3a80dd14344ffccae')
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C') # Kovid Goyal
prepare() {
diff --git a/shade-transparency.patch b/shade-transparency.patch
index bf9b0e2a421b..54f36c57ef5c 100644
--- a/shade-transparency.patch
+++ b/shade-transparency.patch
@@ -106,7 +106,7 @@ index aa65064bf..504a30a12 100644
from .fonts.render import set_font_family
from .options.types import Options
from .options.utils import DELETE_ENV_VAR
- from .os_window_size import initial_window_size_func
+ from .os_window_size import edge_spacing, initial_window_size_func
from .session import create_sessions, get_os_window_sizing_data
from .shaders import CompileError, load_shader_programs
@@ -287,12 +287,13 @@ def __init__(self) -> None: