summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMrElendig2016-12-02 19:19:43 +0100
committerMrElendig2016-12-02 19:21:30 +0100
commita7662605e867ea429104295413a245602e5fcb66 (patch)
tree2a5a8af00fe4d073f5061061efbf4b36848510a0
parent258fad7ae6365e0906fb98e2b3cd794d5f0220ea (diff)
downloadaur-a7662605e867ea429104295413a245602e5fcb66.tar.gz
Update due to changes to upstream packaging.
Add setuptools dependency and manual copy of the config.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e89842d1b291..deb470b21626 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = kittypack-git
pkgdesc = A silly little tool to get info from archlinux.org/packages
- pkgver = 20150321.19
+ pkgver = 0.2
pkgrel = 1
url = https://github.com/MrElendig/kittypack
arch = any
@@ -12,6 +12,7 @@ pkgbase = kittypack-git
depends = python-docopt
depends = python-yaml
depends = python-curtsies
+ depends = python-setuptools
backup = etc/kittypack.conf
source = git://github.com/MrElendig/kittypack.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 22b2ae159176..e2368f09c550 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Øyvind 'Mr.Elendig' Heggstad <mrelendig@har-ikkje.net>>
pkgname=kittypack-git
-pkgver=20150321.19
+pkgver=0.2
pkgrel=1
pkgdesc="A silly little tool to get info from archlinux.org/packages"
arch=('any')
url="https://github.com/MrElendig/kittypack"
license=('AGPL3')
depends=('python' 'python-requests' 'python-docopt' 'python-yaml'
- 'python-curtsies')
+ 'python-curtsies' 'python-setuptools')
makedepends=('git' 'python-docutils')
backup=('etc/kittypack.conf')
source=(git://github.com/MrElendig/kittypack.git)
@@ -15,9 +15,7 @@ sha1sums=('SKIP')
pkgver() {
cd kittypack
- _d=$(git log -n 1 --pretty=%ad --date=short | sed 's/-//g')
- _c=$(git log --pretty=%h | wc -l)
- printf '%s.%s' $_d $_c
+ git describe | sed 's/-/./g'
}
build() {
@@ -29,6 +27,7 @@ package() {
cd kittypack
python3 setup.py install --root="$pkgdir"
install -D doc/man/kittypack.1 "$pkgdir"/usr/share/man/man1/kittypack.1
+ install -D kittypack/kittypack.conf "$pkgdir"/etc/kittypack.conf
}
# vim:set ts=2 sw=2 et: