summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-14 15:25:04 +0800
committerzxp198210052024-03-14 15:25:04 +0800
commit15241cafa63fb2c69822cef2a04036c7e85459f8 (patch)
tree1a3534d168bfb65965684c894e607988c66267a4
parent35cdc502ebd8a7b7c79dd9f7b051f38609f7ad3c (diff)
downloadaur-15241cafa63fb2c69822cef2a04036c7e85459f8.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--kiwiirc-desktop.sh5
3 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc9b060b349c..539f37be0ae2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = kiwiirc-desktop-bin
pkgdesc = Next generation of the Kiwi IRC web client
pkgver = 1.7.1
- pkgrel = 5
+ pkgrel = 6
url = https://kiwiirc.com/
arch = armv7h
arch = aarch64
arch = x86_64
license = Apache-2.0
- depends = electron25
+ depends = electron25-bin
depends = hicolor-icon-theme
provides = kiwiirc=1.7.1
conflicts = kiwiirc-desktop
conflicts = kiwiirc
source = kiwiirc-desktop.sh
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_armv7h = kiwiirc-desktop-1.7.1-armv7h.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.1/kiwiirc-desktop_v1.7.1-2_linux_armv7l.deb
sha256sums_armv7h = 52b315f259afac82cc29c362addb3e9ee13362a9533619471d1b51110e310099
source_aarch64 = kiwiirc-desktop-1.7.1-aarch64.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.1/kiwiirc-desktop_v1.7.1-2_linux_arm64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 0fe8ed81dc2b..b219fab64e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=kiwiirc-desktop-bin
_appname="Kiwi IRC"
pkgver=1.7.1
_electronversion=25
-pkgrel=5
+pkgrel=6
pkgdesc="Next generation of the Kiwi IRC web client"
arch=(
'armv7h'
@@ -19,14 +19,14 @@ conflicts=(
"${pkgname%-desktop-bin}"
)
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
'hicolor-icon-theme'
)
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_armv7l.deb")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_armv7h=('52b315f259afac82cc29c362addb3e9ee13362a9533619471d1b51110e310099')
sha256sums_aarch64=('e6735265dd06b5b76254dd00e54a6253468b8eb2c9306c3189143b47a42c4c6d')
sha256sums_x86_64=('94c71d9d625b4efae0b4862a1702bd6b18fe942cf2834196e43c5121dd5d7213')
@@ -34,6 +34,7 @@ build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_appname}/${pkgname%-bin}\"|${pkgname%-bin}|g;s|chat|Network|g" \
diff --git a/kiwiirc-desktop.sh b/kiwiirc-desktop.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/kiwiirc-desktop.sh
+++ b/kiwiirc-desktop.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file