summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-06 13:11:34 +0800
committerzxp198210052024-03-06 13:11:34 +0800
commit35cdc502ebd8a7b7c79dd9f7b051f38609f7ad3c (patch)
tree7e66010d41194209a75f83403a170b7b07cc7c85
parente4f12bf29ae89d0af393f73566292471553b3530 (diff)
downloadaur-35cdc502ebd8a7b7c79dd9f7b051f38609f7ad3c.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
-rw-r--r--kiwiirc-desktop.sh3
3 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5692b814bee..dc9b060b349c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = kiwiirc-desktop-bin
pkgdesc = Next generation of the Kiwi IRC web client
pkgver = 1.7.1
- pkgrel = 4
+ pkgrel = 5
url = https://kiwiirc.com/
arch = armv7h
arch = aarch64
arch = x86_64
- license = Apache
+ license = Apache-2.0
depends = electron25
depends = hicolor-icon-theme
provides = kiwiirc=1.7.1
conflicts = kiwiirc-desktop
conflicts = kiwiirc
source = kiwiirc-desktop.sh
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
source_armv7h = kiwiirc-desktop-1.7.1-armv7h.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.1/kiwiirc-desktop_v1.7.1-2_linux_armv7l.deb
sha256sums_armv7h = 52b315f259afac82cc29c362addb3e9ee13362a9533619471d1b51110e310099
source_aarch64 = kiwiirc-desktop-1.7.1-aarch64.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.1/kiwiirc-desktop_v1.7.1-2_linux_arm64.deb
diff --git a/PKGBUILD b/PKGBUILD
index b75822122564..0fe8ed81dc2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=kiwiirc-desktop-bin
_appname="Kiwi IRC"
pkgver=1.7.1
_electronversion=25
-pkgrel=4
+pkgrel=5
pkgdesc="Next generation of the Kiwi IRC web client"
arch=(
'armv7h'
@@ -12,7 +12,7 @@ arch=(
)
url="https://kiwiirc.com/"
_ghurl="https://github.com/kiwiirc/kiwiirc"
-license=('Apache')
+license=('Apache-2.0')
provides=("${pkgname%-desktop-bin}=${pkgver}")
conflicts=(
"${pkgname%-bin}"
@@ -26,7 +26,7 @@ source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/downloa
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
sha256sums_armv7h=('52b315f259afac82cc29c362addb3e9ee13362a9533619471d1b51110e310099')
sha256sums_aarch64=('e6735265dd06b5b76254dd00e54a6253468b8eb2c9306c3189143b47a42c4c6d')
sha256sums_x86_64=('94c71d9d625b4efae0b4862a1702bd6b18fe942cf2834196e43c5121dd5d7213')
@@ -35,7 +35,7 @@ build() {
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
- bsdtar -xf "${srcdir}/data.tar.xz"
+ bsdtar -xf "${srcdir}/data."*
sed "s|\"/opt/${_appname}/${pkgname%-bin}\"|${pkgname%-bin}|g;s|chat|Network|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
diff --git a/kiwiirc-desktop.sh b/kiwiirc-desktop.sh
index f9ced1432cfc..86cb3dc6a9bf 100644
--- a/kiwiirc-desktop.sh
+++ b/kiwiirc-desktop.sh
@@ -1,10 +1,11 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then