summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-06-08 12:08:17 +0800
committerzxp198210052023-06-08 12:08:17 +0800
commit4935054e37351687eba04138b494fdc06c010748 (patch)
tree26ce8890f361ea295c940352e09c7e6026719e1d
downloadaur-4935054e37351687eba04138b494fdc06c010748.tar.gz
first release
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD23
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9de4719da9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = kiwiirc-desktop-bin
+ pkgdesc = Next generation of the Kiwi IRC web client
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://kiwiirc.com/
+ arch = armv7h
+ arch = aarch64
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = libxcomposite
+ depends = cairo
+ depends = mesa
+ depends = glib2
+ depends = nspr
+ depends = libxkbcommon
+ depends = libxext
+ depends = gcc-libs
+ depends = libxdamage
+ depends = at-spi2-core
+ depends = libdrm
+ depends = expat
+ depends = glibc
+ depends = gtk3
+ depends = libxcb
+ depends = alsa-lib
+ depends = dbus
+ depends = gdk-pixbuf2
+ depends = nss
+ depends = hicolor-icon-theme
+ depends = libxfixes
+ depends = pango
+ depends = libx11
+ depends = libcups
+ depends = libxrandr
+ conflicts = kiwiirc-desktop
+ conflicts = kiwiirc-desktop-appimage
+ conflicts = kiwiirc
+ source_armv7h = kiwiirc-desktop-1.6.1-armv7h.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.6.1/kiwiirc-desktop_v1.6.1-1_linux_armv7l.deb
+ sha256sums_armv7h = b0dfe2645072892650551e72b8327de772700a6f62db7711275247264a21fcbd
+ source_aarch64 = kiwiirc-desktop-1.6.1-aarch64.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.6.1/kiwiirc-desktop_v1.6.1-1_linux_arm64.deb
+ sha256sums_aarch64 = 262da25b39d9d273e17c02b55418f9a28b722e142f44d4edd703e8cb8d22ee4a
+ source_i686 = kiwiirc-desktop-1.6.1-i686.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.6.1/kiwiirc-desktop_v1.6.1-1_linux_i386.deb
+ sha256sums_i686 = 1d8d5f739b4664317923a3a996926d4d858ce330524f64ce95a8fd836304a134
+ source_x86_64 = kiwiirc-desktop-1.6.1-x86_64.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.6.1/kiwiirc-desktop_v1.6.1-1_linux_amd64.deb
+ sha256sums_x86_64 = 7b59f5d524e247447d002ede6b4fa2bdb3c31db6a0a7648ef58030c3e2edfdf6
+
+pkgname = kiwiirc-desktop-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ef6d72ff02e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=kiwiirc-desktop-bin
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Next generation of the Kiwi IRC web client"
+arch=('armv7h' 'aarch64' 'i686' 'x86_64')
+url="https://kiwiirc.com/"
+_githuburl="https://github.com/kiwiirc/kiwiirc"
+license=('Apache')
+conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage" "kiwiirc")
+depends=('libxcomposite' 'cairo' 'mesa' 'glib2' 'nspr' 'libxkbcommon' 'libxext' 'gcc-libs' 'libxdamage' 'at-spi2-core' 'libdrm' 'expat' \
+ 'glibc' 'gtk3' 'libxcb' 'alsa-lib' 'dbus' 'gdk-pixbuf2' 'nss' 'hicolor-icon-theme' 'libxfixes' 'pango' 'libx11' 'libcups' 'libxrandr')
+source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-1_linux_armv7l.deb")
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-1_linux_arm64.deb")
+source_i686=("${pkgname%-bin}-${pkgver}-i686.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-1_linux_i386.deb")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-1_linux_amd64.deb")
+sha256sums_armv7h=('b0dfe2645072892650551e72b8327de772700a6f62db7711275247264a21fcbd')
+sha256sums_aarch64=('262da25b39d9d273e17c02b55418f9a28b722e142f44d4edd703e8cb8d22ee4a')
+sha256sums_i686=('1d8d5f739b4664317923a3a996926d4d858ce330524f64ce95a8fd836304a134')
+sha256sums_x86_64=('7b59f5d524e247447d002ede6b4fa2bdb3c31db6a0a7648ef58030c3e2edfdf6')
+package() {
+ bsdtar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+} \ No newline at end of file