summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-07 11:46:24 +0800
committerzxp198210052023-08-07 11:46:24 +0800
commitc9ce819cf4e2f082dc39040d0eb23d08ec2be869 (patch)
tree31eab1a7db42a4c2422c5077cab76b1411340287
parent028bd49bf9e1cb2e277964bc567e70438a20173a (diff)
downloadaur-c9ce819cf4e2f082dc39040d0eb23d08ec2be869.tar.gz
fix errors
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
-rw-r--r--kiwiirc-desktop.sh2
3 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4aea4859c0b2..c3dc967c50d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = kiwiirc-desktop-bin
pkgdesc = Next generation of the Kiwi IRC web client
pkgver = 1.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://kiwiirc.com/
arch = armv7h
arch = aarch64
arch = x86_64
license = Apache
depends = bash
- depends = electron
+ depends = electron25
depends = hicolor-icon-theme
conflicts = kiwiirc-desktop
- conflicts = kiwiirc-desktop-appimage
conflicts = kiwiirc
source = kiwiirc-desktop.sh
- sha256sums = 910e669d54b87987493af8d0f44acdc97130e6e76573607f0d3150880f274a16
+ sha256sums = 0d7be737f12933bc5cd596c564df9bba5e3a15aefde284ef078861914ba7b477
source_armv7h = kiwiirc-desktop-1.7.0-armv7h.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.0/kiwiirc-desktop_v1.7.0-1_linux_armv7l.deb
sha256sums_armv7h = ca8521d2ec32ff46e704c066edd674512bacfb934d5bb0a55f30a320db42119e
source_aarch64 = kiwiirc-desktop-1.7.0-aarch64.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.0/kiwiirc-desktop_v1.7.0-1_linux_arm64.deb
diff --git a/PKGBUILD b/PKGBUILD
index ded77c16c0d3..57e9064333f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=kiwiirc-desktop-bin
pkgver=1.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Next generation of the Kiwi IRC web client"
arch=('armv7h' 'aarch64' 'x86_64')
url="https://kiwiirc.com/"
_githuburl="https://github.com/kiwiirc/kiwiirc"
license=('Apache')
-conflicts=("${pkgname%-bin}" "${pkgname%-bin}-appimage" "kiwiirc")
-depends=('bash' 'electron' 'hicolor-icon-theme')
+conflicts=("${pkgname%-bin}" "${pkgname%-desktop-bin}")
+depends=('bash' 'electron25' 'hicolor-icon-theme')
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-1_linux_armv7l.deb")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-1_linux_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_githuburl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-1_linux_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('910e669d54b87987493af8d0f44acdc97130e6e76573607f0d3150880f274a16')
+sha256sums=('0d7be737f12933bc5cd596c564df9bba5e3a15aefde284ef078861914ba7b477')
sha256sums_armv7h=('ca8521d2ec32ff46e704c066edd674512bacfb934d5bb0a55f30a320db42119e')
sha256sums_aarch64=('439f5c22df0260d4d7f599e94d532f3f842951a70aaf46121c025be48d90397f')
sha256sums_x86_64=('89c9bc3b7e17c5592c5b270d68d597fe9e2a6e46905e9420afc82468bd3abdb9')
diff --git a/kiwiirc-desktop.sh b/kiwiirc-desktop.sh
index 96f36580ff14..cdd24ab52926 100644
--- a/kiwiirc-desktop.sh
+++ b/kiwiirc-desktop.sh
@@ -1,5 +1,5 @@
#!/bin/bash
-_ELECTRON=/usr/bin/electron
+_ELECTRON=/usr/bin/electron25
_ASAR="/opt/kiwiirc-desktop/kiwiirc-desktop.asar"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
exec ${_ELECTRON} ${_ASAR} "$@"