summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-04 10:17:49 +0800
committerzxp198210052024-01-04 10:17:49 +0800
commitfc4cc55e804c848227673918faf7254633f3a721 (patch)
tree8b122cb50bf0639dfd5d38d3e57f5c755a2a0189
parent2fb18f327075b54f06b8ce2d3d8c40b27560bf8f (diff)
downloadaur-fc4cc55e804c848227673918faf7254633f3a721.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--kiwiirc-desktop.sh22
3 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28c315a61550..3c4086e27e6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kiwiirc-desktop-bin
pkgdesc = Next generation of the Kiwi IRC web client
pkgver = 1.7.1
- pkgrel = 2
+ pkgrel = 3
url = https://kiwiirc.com/
arch = armv7h
arch = aarch64
@@ -13,7 +13,7 @@ pkgbase = kiwiirc-desktop-bin
conflicts = kiwiirc-desktop
conflicts = kiwiirc
source = kiwiirc-desktop.sh
- sha256sums = de62ed6306328b9c24eafc0335f3b042efc2ecfe77450692b2b04e0f86c4eb95
+ sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
source_armv7h = kiwiirc-desktop-1.7.1-armv7h.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.1/kiwiirc-desktop_v1.7.1-2_linux_armv7l.deb
sha256sums_armv7h = 52b315f259afac82cc29c362addb3e9ee13362a9533619471d1b51110e310099
source_aarch64 = kiwiirc-desktop-1.7.1-aarch64.deb::https://github.com/kiwiirc/kiwiirc/releases/download/v1.7.1/kiwiirc-desktop_v1.7.1-2_linux_arm64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 88807c49f93d..58cfb80b4f76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
pkgname=kiwiirc-desktop-bin
_appname="Kiwi IRC"
pkgver=1.7.1
-pkgrel=2
+_electronversion=25
+pkgrel=3
pkgdesc="Next generation of the Kiwi IRC web client"
arch=(
'armv7h'
@@ -15,20 +16,24 @@ license=('Apache')
provides=("${pkgname%-desktop-bin}=${pkgver}")
conflicts=("${pkgname%-bin}" "${pkgname%-desktop-bin}")
depends=(
- 'electron25'
+ "electron${_electronversion}"
'hicolor-icon-theme'
)
source_armv7h=("${pkgname%-bin}-${pkgver}-armv7h.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_armv7l.deb")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_arm64.deb")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.deb::${_ghurl}/releases/download/v${pkgver}/${pkgname%-bin}_v${pkgver}-2_linux_amd64.deb")
source=("${pkgname%-bin}.sh")
-sha256sums=('de62ed6306328b9c24eafc0335f3b042efc2ecfe77450692b2b04e0f86c4eb95')
+sha256sums=('5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
sha256sums_armv7h=('52b315f259afac82cc29c362addb3e9ee13362a9533619471d1b51110e310099')
sha256sums_aarch64=('e6735265dd06b5b76254dd00e54a6253468b8eb2c9306c3189143b47a42c4c6d')
sha256sums_x86_64=('94c71d9d625b4efae0b4862a1702bd6b18fe942cf2834196e43c5121dd5d7213')
build() {
+ sed -e "s|@electronversion@|${_electronversion}|g" \
+ -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@appasar@|app.asar|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|\"/opt/${_appname}/${pkgname%-bin}\" %U|${pkgname%-bin}|g;s|chat|Network|g" \
+ sed "s|\"/opt/${_appname}/${pkgname%-bin}\"|${pkgname%-bin}|g;s|chat|Network|g" \
-i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
diff --git a/kiwiirc-desktop.sh b/kiwiirc-desktop.sh
index 74842db40f20..c77c53567639 100644
--- a/kiwiirc-desktop.sh
+++ b/kiwiirc-desktop.sh
@@ -1,11 +1,17 @@
-#!/bin/bash
-_ELECTRON=/usr/bin/electron25
-APPDIR="/usr/lib/kiwiirc-desktop"
-export PATH="${APPDIR}:${PATH}"
-#export LD_LIBRARY_PATH="${APPDIR}/swiftshader:${LD_LIBRARY_PATH}"
-_ASAR="${APPDIR}/app.asar"
+#!/bin/sh
+set -e
+_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec ${_ELECTRON} ${_ASAR} "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" "$@"
+ exit
else
- exec ${_ELECTRON} ${_ASAR} --no-sandbox "$@"
+ cd "${_APPDIR}"
+ exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
+ exit
fi \ No newline at end of file