summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoon Sungjoon2023-10-13 23:12:05 +0900
committerMoon Sungjoon2023-10-13 23:12:05 +0900
commitf3dcbabbdfbf8828e26e88e0eef2a113bfa3b1e4 (patch)
treec21580d76fe76179736145f70b7a48fa81cf0353
downloadaur-f3dcbabbdfbf8828e26e88e0eef2a113bfa3b1e4.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD41
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c57e0f8a33ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = kiwitalk-bin
+ pkgdesc = An UNOFFICIAL cross-platform KakaoTalk client written in TypeScript & Rust
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/KiwiTalk/KiwiTalk
+ arch = x86_64
+ license = Apache
+ depends = cairo
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = openssl-1.1
+ depends = pango
+ depends = webkit2gtk
+ depends = libappindicator-gtk3
+ provides = kiwitalk
+ conflicts = kiwitalk
+ source = https://github.com/KiwiTalk/KiwiTalk/releases/download/v0.2.3/kiwi-talk_0.2.3_amd64.deb
+ sha256sums = 0a75d503b68348a1a6de9c8ff5edaa384c29a72f5eb22499a0c7efbf039ff40a
+
+pkgname = kiwitalk-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07a1709cd2be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Moon Sungjoon <sumoon at seoulsaram dot org>
+
+pkgname=kiwitalk-bin
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="An UNOFFICIAL cross-platform KakaoTalk client written in TypeScript & Rust"
+arch=('x86_64')
+url="https://github.com/KiwiTalk/KiwiTalk"
+license=('Apache')
+conflicts=('kiwitalk')
+provides=('kiwitalk')
+depends=('cairo' 'gdk-pixbuf2' 'glib2' 'gtk3' 'hicolor-icon-theme' 'openssl-1.1' 'pango' 'webkit2gtk' 'libappindicator-gtk3')
+
+_prgname="kiwi-talk"
+_debfile="${_prgname}_${pkgver}_amd64.deb"
+source=("https://github.com/KiwiTalk/KiwiTalk/releases/download/v${pkgver}/${_debfile}")
+sha256sums=('0a75d503b68348a1a6de9c8ff5edaa384c29a72f5eb22499a0c7efbf039ff40a')
+
+#sudo apt-get install -y libgtk-3-dev libwebkit2gtk-4.0-dev libappindicator3-dev librsvg2-dev patchelf
+prepare() {
+ ar x ${_debfile}
+ bsdtar -xf data.tar.gz
+ rm -f data.tar.gz
+}
+
+package() {
+ cd "$srcdir"
+
+ # Install binaries
+ install -Dm755 usr/bin/${_prgname} -t "$pkgdir/usr/bin/"
+
+ # Install desktop file from deb
+ install -Dm644 "usr/share/applications/${_prgname}.desktop" -t \
+ "$pkgdir/usr/share/applications/"
+
+ # Install desktop icons from deb
+ for icon_size in 32 128 256 512; do
+ icons_dir="usr/share/icons/hicolor/${icon_size}x${icon_size}/apps"
+ install -Dm644 "${icons_dir}/${_prgname}.png" -t "$pkgdir/${icons_dir}/"
+ done
+}