summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeromy Reimer2015-06-27 11:34:51 -0600
committerJeromy Reimer2015-06-27 11:34:51 -0600
commit516d1ce619ef0b0e2a396d39d6f671cadae07e69 (patch)
tree1194eddb3d7cddf8f4e06d0c204b9a7170d0a7c7
downloadaur-516d1ce619ef0b0e2a396d39d6f671cadae07e69.tar.gz
Initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD29
-rw-r--r--kiwix.desktop12
-rw-r--r--kiwix.install14
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d6ab029de95
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kiwix-bin
+ pkgdesc = Offline reader for Web content. It's especially intended to make Wikipedia available offline.
+ pkgver = 0.9
+ pkgrel = 1
+ url = http://www.kiwix.org
+ install = kiwix.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = rpcbind
+ depends = gtk2
+ depends = alsa-lib
+ depends = libxt
+ depends = libcanberra
+ depends = sqlite3
+ depends = java-environment
+ provides = kiwix
+ conflicts = kiwix
+
+pkgname = kiwix-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34c7c2f704bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: jernick
+pkgname=kiwix-bin
+pkgver=0.9
+pkgrel=1
+pkgdesc="Offline reader for Web content. It's especially intended to make Wikipedia available offline."
+arch=('i686' 'x86_64')
+url="http://www.kiwix.org"
+license=('GPL3')
+depends=('rpcbind' 'gtk2' 'alsa-lib' 'libxt' 'libcanberra' 'sqlite3' 'java-environment')
+provides=('kiwix')
+conflicts=('kiwix')
+install='kiwix.install'
+[[ "$CARCH" == 'x86_64' ]] && source=("http://sourceforge.net/projects/kiwix/files/$pkgver/kiwix-$pkgver-linux-x86_64.tar.bz2" "kiwix.desktop") && md5sums=('df6216ba851819d9c3d0208d3ea639df' '28f6bc22e23a3a73e60bbcf632b65827')
+[[ "$CARCH" == 'i686' ]] && source=("http://sourceforge.net/projects/kiwix/files/$pkgver/kiwix-$pkgver-linux-i686.tar.bz2" "kiwix.desktop") && md5sums=('b61fdc3937aa226f34f685ba0bc29db1' '28f6bc22e23a3a73e60bbcf632b65827')
+
+#build() {
+#}
+
+package() {
+ mkdir -p ${pkgdir}/usr/lib
+ mkdir -p ${pkgdir}/usr/bin
+ cp -R -d ${srcdir}/kiwix ${pkgdir}/usr/lib/
+ find ${pkgdir}/usr/lib/kiwix -perm -u=w -exec chmod a+w {} \; #Set permisions
+ find ${pkgdir}/usr/lib/kiwix -perm -u=r -exec chmod a+r {} \;
+ find ${pkgdir}/usr/lib/kiwix -perm -u=x -exec chmod a+x {} \;
+ ln -f -s /usr/lib/kiwix/kiwix ${pkgdir}/usr/bin/kiwix
+ install -D -m644 ${srcdir}/kiwix.desktop ${pkgdir}/usr/share/applications/kiwix.desktop
+ install -D -m644 ${srcdir}/kiwix/chrome/icons/default/main.png ${pkgdir}/usr/share/icons/hicolor/64x64/apps/kiwix.png
+}
diff --git a/kiwix.desktop b/kiwix.desktop
new file mode 100644
index 000000000000..ec3bd047b2ce
--- /dev/null
+++ b/kiwix.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=Kiwix
+GenericName= Offline reader for Web content
+GenericName[es]=Lector de contenido web sin conexión
+Comment=It's especially intended to make Wikipedia available offline.
+Comment[es]=Está especialmente concebido para acceder a la Wikipedia sin conexión.
+Exec=kiwix
+Icon=kiwix
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=Education;
diff --git a/kiwix.install b/kiwix.install
new file mode 100644
index 000000000000..aa507cce2a81
--- /dev/null
+++ b/kiwix.install
@@ -0,0 +1,14 @@
+post_remove() {
+ echo
+ echo " WARNING:"
+ echo "You may have huge files under the ~/.www.kiwix.org folder (e.g. the wikipedia)."
+ echo "Please consider if you want to leave them there."
+ echo
+ if expr match $LANG es >/dev/null ; then
+ echo " ADVERTENCIA:"
+ echo "Es posible que tengas archivos enormes bajo la carpeta ~/.www.kiwix.org (por ejemplo, la wikipedia)"
+ echo "Por favor, considera si quieres dejarlos donde estan."
+ echo
+ fi
+ }
+ \ No newline at end of file