summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeromy Reimer2019-08-12 13:34:02 -0600
committerJeromy Reimer2019-08-12 13:34:02 -0600
commit38556b5a8753c3af10b476cd9ea9a76bdda867d1 (patch)
treeeab3ba86ff141e917d17747e0e5a0d876a36582d
downloadaur-38556b5a8753c3af10b476cd9ea9a76bdda867d1.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72f53eb09e62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kiwix-desktop
+ pkgver = 2.0rc1
+ pkgrel = 1
+ url = https://www.kiwix.org/
+ arch = any
+ license = GPLv3
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-webengine
+ depends = qt5-svg
+ depends = qt5-imageformats
+ depends = aria2
+ depends = kiwix-lib
+ conflicts = kiwix-bin
+ source = https://download.kiwix.org/release/kiwix-desktop/kiwix-desktop-2.0-rc1.tar.gz
+ md5sums = ce648a2a7e47366e8fe0ae7fa6f054da
+
+pkgname = kiwix-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa67223f77cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: nic96
+pkgname=kiwix-desktop
+pkgver=2.0rc1
+url_ver=2.0-rc1
+pkgrel=1
+pkgdesc=""
+url="https://www.kiwix.org/"
+arch=("any")
+license=('GPLv3')
+depends=("qt5-base" "qt5-webengine" "qt5-svg" "qt5-imageformats" "aria2" "kiwix-lib")
+makedepends=("qt5-tools")
+source=("https://download.kiwix.org/release/kiwix-desktop/kiwix-desktop-$url_ver.tar.gz")
+conflicts=("kiwix-bin")
+md5sums=('ce648a2a7e47366e8fe0ae7fa6f054da')
+
+build() {
+ cd "$srcdir/$pkgname-$url_ver"
+ qmake PREFIX=$pkgdir/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$url_ver"
+ make install
+}