summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhashworks2020-06-17 21:27:09 +0200
committerhashworks2020-06-17 21:27:09 +0200
commitbad1036f7b07b566b328b9a1ec1c213648a641b2 (patch)
tree9aeab9639351c89c930caa62f50a0f2d7f2561ae
parent312163ba8f45904773a4b733a853aff289d4af62 (diff)
downloadaur-bad1036f7b07b566b328b9a1ec1c213648a641b2.tar.gz
Add CPPFLAGS workaround
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18e3af570e07..1323b8d2b8d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = kiwix-desktop-git
pkgdesc = Offline reader for Web content, especially intended to make Wikipedia available offline
- pkgver = 2.0.1.r13.g2c98856
- pkgrel = 2
+ pkgver = 2.0.1.r16.g8430ee8
+ pkgrel = 1
url = https://github.com/kiwix/kiwix-desktop
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7714abbc9bac..65e2093c6190 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: hashworks <mail@hashworks.net>
-# Contributor: soloturn@gmail.com
+# Contributor: soloturn@gmail.com
# Contributor: nic96
pkgname=kiwix-desktop-git
_pkgname="${pkgname%-git}"
-pkgver=2.0.1.r13.g2c98856
-pkgrel=2
+pkgver=2.0.1.r16.g8430ee8
+pkgrel=1
pkgdesc="Offline reader for Web content, especially intended to make Wikipedia available offline"
url="https://github.com/kiwix/kiwix-desktop"
arch=("i686" "x86_64")
@@ -24,6 +24,8 @@ pkgver() {
build() {
cd "$srcdir/${_pkgname}"
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
qmake PREFIX="${pkgdir}/usr"
make
}