summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsoloturn2019-12-26 10:28:40 +0100
committersoloturn2019-12-26 10:28:40 +0100
commitc00db7c1d6e8b01c4fa26802a5d79d80d159065d (patch)
treeea3b358e5a16d9df911cd1520c5aae8058ef1bc5
downloadaur-c00db7c1d6e8b01c4fa26802a5d79d80d159065d.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD30
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8925933d4e42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = kiwix-desktop-git
+ pkgdesc = Offline reader for Web content, especially intended to make Wikipedia available offline.
+ pkgver = 2.0
+ pkgrel = 1
+ url = https://www.kiwix.org/
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-webengine
+ depends = qt5-svg
+ depends = qt5-imageformats
+ depends = kiwix-lib
+ provides = kiwix-desktop
+ conflicts = kiwix-desktop
+ source = kiwix-desktop-git::git://github.com/kiwix/kiwix-desktop.git
+ md5sums = SKIP
+
+pkgname = kiwix-desktop-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..80dcdb373902
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+/kiwix-desktop*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92686a1fbdc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: soloturn@gmail.com
+# Contributor: nic96
+
+_basename=kiwix-desktop
+pkgname="$_basename-git"
+pkgver=2.0
+pkgrel=1
+pkgdesc="Offline reader for Web content, especially intended to make Wikipedia available offline."
+url="https://www.kiwix.org/"
+arch=('i686' 'x86_64')
+license=('GPLv3')
+depends=("qt5-base" "qt5-webengine" "qt5-svg" "qt5-imageformats" "kiwix-lib")
+makedepends=("qt5-tools")
+conflicts=("$_basename")
+provides=("$_basename")
+
+source=("$pkgname::git://github.com/kiwix/$_basename.git")
+md5sums=('SKIP')
+
+build() {
+ cd $pkgname
+ qmake PREFIX=$pkgdir/usr
+ make
+}
+
+package() {
+ cd $pkgname
+ make install
+}
+