summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Cooper2018-08-11 11:34:12 -0300
committerTim Cooper2018-08-11 11:34:12 -0300
commita2d37cdd43d668fd7f6f6f28672029f28089eb8a (patch)
tree77d2e50819bd8eaf3664fefba28fc2001516305d
downloadaur-a2d37cdd43d668fd7f6f6f28672029f28089eb8a.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d70c75d3fbab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = kjv-git
+ pkgdesc = Read the Bible, God's Word, from your terminal
+ pkgver = r12.996c670
+ pkgrel = 1
+ url = https://github.com/bontibon/kjv
+ arch = any
+ license = custom:Public Domain
+ depends = bash
+ source = kjv::git+https://github.com/bontibon/kjv.git
+ md5sums = SKIP
+
+pkgname = kjv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b22c9b58bf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tim Cooper <tim.cooper@layeh.com>
+pkgname=kjv-git
+pkgver=r12.996c670
+pkgrel=1
+pkgdesc="Read the Bible, God's Word, from your terminal"
+arch=(any)
+depends=(bash)
+url="https://github.com/bontibon/kjv"
+license=('custom:Public Domain')
+source=('kjv::git+https://github.com/bontibon/kjv.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 kjv $pkgdir/usr/bin/kjv
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/${pkgname}/LICENSE
+}