summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Luc Tambasco2018-10-02 18:25:34 +1000
committerJean-Luc Tambasco2018-10-02 18:25:34 +1000
commit17d1c088bfe70d7b374145de9be858804e8d42d9 (patch)
tree63561eaf299df0c7e704b1e7e1625eacfacd3a87
downloadaur-17d1c088bfe70d7b374145de9be858804e8d42d9.tar.gz
Added files.
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD57
-rw-r--r--klayoutEditor.desktop13
-rw-r--r--klayoutViewer.desktop13
-rw-r--r--missingOp.patch15
5 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6207d28a5d5d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = klayout-git
+ pkgdesc = High Performance Layout Viewer And Editor. Support of GDS and OASIS files.
+ pkgver = v0.25.4.r47.g9dd603bb
+ pkgrel = 1
+ url = http://www.klayout.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt5-base
+ depends = qt5-tools
+ depends = qt5-multimedia
+ depends = qt5-xmlpatterns
+ depends = qt5-svg
+ depends = ruby2.3
+ depends = python
+ source = klayout::git+https://github.com/klayoutmatthias/klayout#branch=master
+ source = klayoutEditor.desktop
+ source = klayoutViewer.desktop
+ source = missingOp.patch
+ md5sums = SKIP
+ md5sums = e790f7fca3c1138e21068d7927fb8ff4
+ md5sums = e6b98e9146c476a5cb76162999964aa8
+ md5sums = 553b08ddcf6c2338115a8c85ff1c948c
+
+pkgname = klayout-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c740b79d3da2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Jean-Luc Tambasco <an.obscurity@gmail.com>
+# Based off `klayout` Arch AUR package.
+
+_pkgname=klayout
+pkgname=klayout-git
+pkgver=v0.25.4.r47.g9dd603bb
+pkgrel=1
+pkgdesc="High Performance Layout Viewer And Editor. Support of GDS and OASIS files."
+arch=('i686' 'x86_64')
+url="http://www.klayout.org/"
+license=('GPL')
+depends=('qt5-base' 'qt5-tools' 'qt5-multimedia' 'qt5-xmlpatterns' 'qt5-svg' 'ruby2.3' 'python')
+source=(
+ 'klayout::git+https://github.com/klayoutmatthias/klayout#branch=master'
+ klayoutEditor.desktop
+ klayoutViewer.desktop
+ missingOp.patch
+)
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/klayout"
+ build_opt="-qmake /usr/bin/qmake
+ -ruby /usr/bin/ruby-2.3
+ -python /usr/bin/python3"
+
+ # apply patch
+ cd ./src/db/db
+ cat ../../../../../missingOp.patch | patch
+ cd ../../../
+
+ ./build.sh $build_opt
+}
+package() {
+ cd "$srcdir"
+ install -D -m 644 klayoutEditor.desktop ${pkgdir}/usr/share/applications/klayoutEditor.desktop
+ install -D -m 644 klayoutViewer.desktop ${pkgdir}/usr/share/applications/klayoutViewer.desktop
+ cd klayout-${pkgver}
+ install -D -m 644 etc/logo.png ${pkgdir}/usr/share/icons/hicolor/32x32/apps/klayout.png
+ install -D -m 755 build-release/klayout ${pkgdir}/usr/bin/klayout
+ cd bin-release
+ for lib in `find . -type f | grep so`; do
+ install -D -m 755 $lib ${pkgdir}/usr/lib/$lib
+ done
+ for lib in `find . -type l | grep so`; do
+ cp -a $lib ${pkgdir}/usr/lib/$lib
+ done
+}
+#
+md5sums=(SKIP
+ 'e790f7fca3c1138e21068d7927fb8ff4'
+ 'e6b98e9146c476a5cb76162999964aa8'
+ '553b08ddcf6c2338115a8c85ff1c948c')
diff --git a/klayoutEditor.desktop b/klayoutEditor.desktop
new file mode 100644
index 000000000000..b19c886aeb06
--- /dev/null
+++ b/klayoutEditor.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Comment[de]=Programm zur Bearbeiten von GDS-Dateien
+Comment=Program to edit GDS and CIF files
+Exec=klayout -e %F
+GenericName[de]=Klayout Editor
+GenericName=Klayout Editor
+Icon=/usr/share/icons/hicolor/32x32/apps/klayout.png
+Name[de]=Klayout Editor
+Name=Klayout Editor
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Scientific;Development
diff --git a/klayoutViewer.desktop b/klayoutViewer.desktop
new file mode 100644
index 000000000000..2103a8b16193
--- /dev/null
+++ b/klayoutViewer.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Comment[de]=Programm zur Betrachten von GDS-Dateien
+Comment=Program to view GDS and CIF files
+Exec=klayout %F
+GenericName[de]=Klayout Viewer
+GenericName=Klayout Viewer
+Icon=/usr/share/icons/hicolor/32x32/apps/klayout.png
+Name[de]=Klayout Viewer
+Name=Klayout Viewer
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Scientific;Development
diff --git a/missingOp.patch b/missingOp.patch
new file mode 100644
index 000000000000..1e1d8d628d1e
--- /dev/null
+++ b/missingOp.patch
@@ -0,0 +1,15 @@
+--- dbCellMapping.cc.o 2018-05-11 11:46:36.416064830 -0400
++++ dbCellMapping.cc 2018-05-11 11:47:02.921846210 -0400
+@@ -75,6 +75,12 @@
+ return *this;
+ }
+
++ SortedCellIndexIterator &operator--()
++ {
++ --m_n;
++ return *this;
++ }
++
+ SortedCellIndexIterator &operator+=(size_t n)
+ {
+ m_n += n;