summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWheelchairArtist2024-10-17 18:36:09 +0200
committerWheelchairArtist2024-10-17 18:41:50 +0200
commit5900aa72215beb305a1148b218ceb4c66d2c7df4 (patch)
treed4e9cdf08ed7c3543d400281d182e94b272f87ee
downloadaur-5900aa72215beb305a1148b218ceb4c66d2c7df4.tar.gz
intial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7d368f51c5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = klevernotes
+ pkgdesc = A convergent markdown note taking application
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://invent.kde.org/office/klevernotes
+ arch = x86_64
+ groups = kde-applications-git
+ groups = kde-utilities-git
+ license = GPL
+ license = LGPL
+ license = BSD
+ makedepends = extra-cmake-modules
+ depends = kio
+ depends = qt6-webengine
+ options = !lto
+ options = !debug
+ source = https://invent.kde.org/office/klevernotes/-/archive/v1.1.0/klevernotes-v1.1.0.tar.gz
+ sha512sums = SKIP
+
+pkgname = klevernotes
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5d4feb2e0565
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+# exclude everything except directory .gitignore, PKGBUILD and .SRCINFO
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a60b60b8d6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: Integral <integral@murena.io>
+# Maintainer: Kazel <address at domain dot tld>
+
+pkgname=klevernotes
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A convergent markdown note taking application"
+
+url="https://invent.kde.org/office/klevernotes"
+arch=('x86_64')
+license=('GPL' 'LGPL' 'BSD')
+options=('!lto' '!debug')
+
+groups=('kde-applications-git' 'kde-utilities-git')
+depends=('kio' 'qt6-webengine')
+makedepends=('extra-cmake-modules')
+
+source=("https://invent.kde.org/office/klevernotes/-/archive/v${pkgver}/klevernotes-v${pkgver}.tar.gz")
+sha512sums=('SKIP')
+
+prepare() {
+ install -d build/
+}
+
+build() {
+ cd build/
+ cmake -B build/ -S ../${pkgname}-v${pkgver} -DBUILD_TESTING=OFF
+ cmake --build build/
+}
+
+package() {
+ cd build/
+ DESTDIR="${pkgdir}/" cmake --install build/
+
+ # Licenses
+ install -Dm644 ${srcdir}/${pkgname}-v${pkgver}/LICENSES/* -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+}