summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAldo Gunsing2018-11-01 20:45:20 +0100
committerAldo Gunsing2018-11-01 21:32:01 +0100
commit81da6142d845de815b986d38932d859cbe7f8a9c (patch)
tree55b3fdb7443fea721969d52cb9384ba47ab46862
parent21cd06ee64a3de62e89575ea301cfb321783fd53 (diff)
downloadaur-81da6142d845de815b986d38932d859cbe7f8a9c.tar.gz
Use old Cabal version again
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD26
2 files changed, 12 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88dd633ceb5d..97737b39c716 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,33 +1,12 @@
pkgbase = klfc
pkgdesc = Tool to create advanced keyboard layouts in various formats
pkgver = 1.5.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/39aldo39/klfc
arch = i686
arch = x86_64
license = GPL3
makedepends = cabal-install
- depends = haskell-base-prelude>=1.2.1
- depends = haskell-text
- depends = haskell-bytestring
- depends = haskell-semigroups
- depends = haskell-containers
- depends = haskell-unordered-containers
- depends = haskell-vector
- depends = haskell-aeson>=0.8.1.0
- depends = haskell-time>=1.5
- depends = haskell-mtl
- depends = haskell-microlens-platform
- depends = haskell-base-unicode-symbols
- depends = haskell-megaparsec>=6
- depends = haskell-filepath
- depends = haskell-directory
- depends = haskell-optparse-applicative
- depends = haskell-transformers
- depends = haskell-file-embed
- depends = haskell-xml
- depends = haskell-chunked-data
- depends = haskell-process>=1.2.0.0
source = https://github.com/39aldo39/klfc/archive/abfc7ebd80a33a20caa50d481cfa46183258dda6.tar.gz
md5sums = 7a317f99e12b95fed8c9f3b85e0ad9c8
diff --git a/PKGBUILD b/PKGBUILD
index c39058f3ce82..ae2214f58fdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,26 @@
pkgname=klfc
pkgver=1.5.3
-pkgrel=2
+pkgrel=3
+commit="abfc7ebd80a33a20caa50d481cfa46183258dda6"
pkgdesc="Tool to create advanced keyboard layouts in various formats"
url="https://github.com/39aldo39/klfc"
license=("GPL3")
arch=("i686" "x86_64")
-depends=("haskell-base-prelude>=1.2.1" "haskell-text" "haskell-bytestring"
- "haskell-semigroups" "haskell-containers" "haskell-unordered-containers"
- "haskell-vector" "haskell-aeson>=0.8.1.0" "haskell-time>=1.5" "haskell-mtl"
- "haskell-microlens-platform" "haskell-base-unicode-symbols" "haskell-megaparsec>=7"
- "haskell-filepath" "haskell-directory" "haskell-optparse-applicative"
- "haskell-transformers" "haskell-file-embed" "haskell-xml" "haskell-chunked-data"
- "haskell-process>=1.2.0.0")
makedepends=("cabal-install")
-source=("https://github.com/39aldo39/klfc/archive/abfc7ebd80a33a20caa50d481cfa46183258dda6.tar.gz")
+source=("https://github.com/39aldo39/klfc/archive/$commit.tar.gz")
md5sums=('7a317f99e12b95fed8c9f3b85e0ad9c8')
build() {
- cd "$srcdir/$pkgname-$pkgver"
- cabal new-update
- cabal new-configure --prefix=/usr --ghc-options=-dynamic
- cabal new-build
+ cd "$srcdir/$pkgname-$commit"
+ cabal v1-sandbox init
+ cabal v1-update
+ cabal v1-install --only-dependencies --ghc-options=-dynamic --force-reinstalls
+ cabal v1-configure --prefix=/usr --ghc-options=-dynamic
+ cabal v1-build
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- cabal copy --destdir="$pkgdir"
+ cd "$srcdir/$pkgname-$commit"
+ cabal v1-copy --destdir="$pkgdir"
}